summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-19 22:09:38 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-19 22:09:38 +0000
commit5f4102f5f27a48777ff207e3b0811232f776facb (patch)
tree71c93831cff499a86c213b2ed3125b62c2265d91 /games-fps/quake3/quake3-9999.ebuild
parentremove stale patches (diff)
downloadhistorical-5f4102f5f27a48777ff207e3b0811232f776facb.tar.gz
historical-5f4102f5f27a48777ff207e3b0811232f776facb.tar.bz2
historical-5f4102f5f27a48777ff207e3b0811232f776facb.zip
Version bump and fix filter-flags. Blame zakk.
Package-Manager: portage-2.1.2_pre3-r3
Diffstat (limited to 'games-fps/quake3/quake3-9999.ebuild')
-rw-r--r--games-fps/quake3/quake3-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/games-fps/quake3/quake3-9999.ebuild b/games-fps/quake3/quake3-9999.ebuild
index e57bffc03ea5..7025fa5489de 100644
--- a/games-fps/quake3/quake3-9999.ebuild
+++ b/games-fps/quake3/quake3-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.6 2006/10/03 15:28:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.7 2006/10/19 22:09:38 wolf31o2 Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -24,8 +24,10 @@ elif [[ ${PV} == *_alpha* ]] ; then
S=${WORKDIR}/${MY_P}
else
inherit flag-o-matic toolchain-funcs eutils games
-
- SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+ MY_PV=${PV/_/-}
+ MY_P=io${PN}_${MY_PV}
+ SRC_URI="http://icculus.org/quake3/files/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
fi
DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
@@ -61,7 +63,7 @@ src_unpack() {
}
src_compile() {
- filter-flag -mfpmath=sse
+ filter-flags -mfpmath=sse
buildit() { use $1 && echo 1 || echo 0 ; }
emake \
BUILD_SERVER=$(buildit dedicated) \