summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-14 04:03:56 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-14 04:03:56 +0000
commit9aff3d0533c1f95e5139a5f90e8642da00e0bd59 (patch)
treee1b74956e1a76837802c08f3efa325e6af22e795 /games-fps/doomlegacy
parentNew version (diff)
downloadhistorical-9aff3d0533c1f95e5139a5f90e8642da00e0bd59.tar.gz
historical-9aff3d0533c1f95e5139a5f90e8642da00e0bd59.tar.bz2
historical-9aff3d0533c1f95e5139a5f90e8642da00e0bd59.zip
fix typo and legacy.dat
Diffstat (limited to 'games-fps/doomlegacy')
-rw-r--r--games-fps/doomlegacy/ChangeLog7
-rw-r--r--games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild87
-rw-r--r--games-fps/doomlegacy/files/digest-doomlegacy-1.41-r13
3 files changed, 96 insertions, 1 deletions
diff --git a/games-fps/doomlegacy/ChangeLog b/games-fps/doomlegacy/ChangeLog
index 0bb074756a83..03a7e3bfc7cd 100644
--- a/games-fps/doomlegacy/ChangeLog
+++ b/games-fps/doomlegacy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/doomlegacy
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/ChangeLog,v 1.3 2003/10/11 05:15:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/ChangeLog,v 1.4 2003/10/14 04:03:56 vapier Exp $
+
+*doomlegacy-1.41-r1 (13 Oct 2003)
+
+ 13 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Fix typo in sed script and fix legacy.dat mirroring.
*doomlegacy-1.41 (11 Oct 2003)
diff --git a/games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild b/games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild
new file mode 100644
index 000000000000..214863177913
--- /dev/null
+++ b/games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild,v 1.1 2003/10/14 04:03:56 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Doom legacy, THE doom port"
+HOMEPAGE="http://legacy.newdoom.com/"
+SRC_URI="mirror://sourceforge/doomlegacy/legacy_${PV/./}_src.tar.gz
+ mirror://gentoo/legacy-${PV}.dat.bz2
+ http://www.lbjhs.net/~jessh/lsdldoom/doom1.wad.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="x86? ( >=dev-lang/nasm-0.98 )
+ >=sys-apps/sed-4
+ virtual/opengl
+ virtual/x11"
+
+S=${WORKDIR}/legacy_${PV//.}_src
+
+src_unpack() {
+ unpack ${A}
+ mkdir bin
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-errno.patch
+ epatch ${FILESDIR}/${PV}-makefile.patch
+
+ # disable logfile writing
+ sed -i 's:#define LOGMESSAGES::' doomdef.h || die 'sed doomdef.h failed'
+
+ # make sure the games can find the wads/data files
+ sed -i \
+ "/#define DEFAULTWADLOCATION1/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ linux_x/i_system.c
+
+ # move opengl lib file because it's not useful to anyone else
+ sed -i "s:\"r_opengl:\"${GAMES_LIBDIR}/${PN}/r_opengl:" linux_x/i_video_xshm.c
+
+ cd linux_x/musserv
+ make -f Makefile.linux clean
+}
+
+src_compile() {
+ # this is ugly but it's late (here) and it works
+ local useasm=
+ [ `use x86` ] && useasm="USEASM=1"
+ local redosnd=0
+ make \
+ EXTRAOPTS="${CFLAGS}" \
+ LINUX=1 \
+ X=1 \
+ ${useasm} \
+ || redosnd=1
+ if [ ${redosnd} -eq 1 ] ; then
+ cd linux_x/sndserv
+ make clean || die "clean snd srv failed"
+ make EXTRAOPTS="${CFLAGS}" || die "snd serv failed"
+ fi
+ cd ${S}
+ make \
+ EXTRAOPTS="${CFLAGS}" \
+ LINUX=1 \
+ X=1 \
+ ${useasm} \
+ || die "build failed"
+}
+
+src_install() {
+ dogamesbin \
+ linux_x/musserv/linux/musserver \
+ linux_x/sndserv/linux/llsndserv \
+ ${WORKDIR}/bin/llxdoom
+ exeinto ${GAMES_LIBDIR}/${PN}
+ doexe ${WORKDIR}/bin/r_opengl.so
+
+ insinto ${GAMES_DATADIR}/${PN}
+ doins ${WORKDIR}/doom1.wad
+ newins ${WORKDIR}/legacy-${PV}.dat legacy.dat
+
+ dohtml _doc/*.html
+ rm _doc/*.html
+ dodoc _doc/*
+ prepgamesdirs
+}
diff --git a/games-fps/doomlegacy/files/digest-doomlegacy-1.41-r1 b/games-fps/doomlegacy/files/digest-doomlegacy-1.41-r1
new file mode 100644
index 000000000000..504a132d5375
--- /dev/null
+++ b/games-fps/doomlegacy/files/digest-doomlegacy-1.41-r1
@@ -0,0 +1,3 @@
+MD5 4e64cb19e0e57055e664bdf09bce14d2 legacy_141_src.tar.gz 1600679
+MD5 03aad1e378ea16cad26c59c63c28c2eb legacy-1.41.dat.bz2 314470
+MD5 66851d7cecbc7845d612e7073c1355ad doom1.wad.gz 1765820