summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2009-07-26 10:28:56 +0000
committerTristan Heaven <tristan@gentoo.org>2009-07-26 10:28:56 +0000
commit74508685c61b6643f5ea052bc57e7b07b04a7e03 (patch)
treefd506a8ba6714d5a2c19ed8a91a6a815ec010bf5 /games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild
parentUpdate for xf86-input-synaptics wrt #236924. (diff)
downloadhistorical-74508685c61b6643f5ea052bc57e7b07b04a7e03.tar.gz
historical-74508685c61b6643f5ea052bc57e7b07b04a7e03.tar.bz2
historical-74508685c61b6643f5ea052bc57e7b07b04a7e03.zip
Version bump by Paul Bredbury, bug #190745
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild')
-rw-r--r--games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild b/games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild
new file mode 100644
index 000000000000..8ee05bf34eae
--- /dev/null
+++ b/games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-chextrek/doom3-chextrek-0.52.ebuild,v 1.1 2009/07/26 10:28:56 nyhm Exp $
+
+MOD_DESC="Green slimeballs mod for kids"
+MOD_NAME="Chex Trek: Beyond the Quest"
+MOD_DIR="chextrek"
+MOD_ICON="flem.ico"
+
+inherit games-mods
+
+MY_PV=${PV/./}
+
+HOMEPAGE="http://doom3.filefront.com/file/Chex_Trek_Beyond_the_Quest;82325"
+SRC_URI="chextrek_beta_${MY_PV}.zip"
+
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch"
+
+RDEPEND="games-fps/doom3"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ elog "Please download ${SRC_URI} from:"
+ elog "http://www.filefront.com/8396958"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ games-mods_src_unpack
+
+ cd "${WORKDIR}"
+ mv -f chextrek_beta* "${MOD_DIR}" || die
+}
+
+pkg_postinst() {
+ games-mods_pkg_postinst
+
+ elog "Press 'E' to open doors in the game."
+ elog "Press 'M' to toggle the map."
+}