summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-16 02:02:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-16 02:02:41 +0000
commit85b2c4ee1cb27f9a9211b9f87d2a29afda821cd6 (patch)
treee6157c561444b3926ae87c20cf8a239cbcea0ff8 /games-emulation
parentAdded SPTK ebuild contibuted by Alexey Parshin (diff)
downloadhistorical-85b2c4ee1cb27f9a9211b9f87d2a29afda821cd6.tar.gz
historical-85b2c4ee1cb27f9a9211b9f87d2a29afda821cd6.tar.bz2
historical-85b2c4ee1cb27f9a9211b9f87d2a29afda821cd6.zip
version bump
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/Manifest4
-rw-r--r--games-emulation/stella/files/digest-stella-1.4.11
-rw-r--r--games-emulation/stella/stella-1.4.1.ebuild40
4 files changed, 50 insertions, 2 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index e959b9bd3aad..1e0678987895 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.11 2004/07/20 06:32:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.12 2004/08/16 02:02:41 mr_bones_ Exp $
+
+*stella-1.4.1 (15 Aug 2004)
+
+ 15 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> +stella-1.4.1.ebuild:
+ version bump
*stella-1.4 (19 Jul 2004)
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index af8e269bca0b..4155077e1cde 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1,7 +1,9 @@
-MD5 99b5711ba1507424782bc6346a859b63 ChangeLog 1445
+MD5 351728a304a3b93339423384f9c1072a ChangeLog 1567
MD5 a38bd1da9bdfd7efdd1f80a2b98bb77c stella-1.4.ebuild 918
MD5 864cb7cce7e9c6b2f182f8b8d0b042e8 stella-1.3-r1.ebuild 1379
+MD5 4cebeab41d200a04149929ce12988a05 stella-1.4.1.ebuild 920
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 f229ddccb6fe3605b1d3e98e48cbfdd9 files/digest-stella-1.4 66
+MD5 f2b2dbff121db9646e0835e732074849 files/digest-stella-1.4.1 68
MD5 5af9244b91231a9124ae00e7620ad00e files/digest-stella-1.3-r1 66
MD5 72f37d51ae26ee356cc4ede6b1438195 files/stella-1.3-alsa-fix.patch 1040
diff --git a/games-emulation/stella/files/digest-stella-1.4.1 b/games-emulation/stella/files/digest-stella-1.4.1
new file mode 100644
index 000000000000..2d3dbc72106d
--- /dev/null
+++ b/games-emulation/stella/files/digest-stella-1.4.1
@@ -0,0 +1 @@
+MD5 079d261d19f1a851c999c183e40c7413 stella-1.4.1-src.tar.gz 707079
diff --git a/games-emulation/stella/stella-1.4.1.ebuild b/games-emulation/stella/stella-1.4.1.ebuild
new file mode 100644
index 000000000000..15499c51b5e3
--- /dev/null
+++ b/games-emulation/stella/stella-1.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-1.4.1.ebuild,v 1.1 2004/08/16 02:02:41 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE="opengl"
+
+DEPEND="virtual/libc
+ media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ local target="linux"
+
+ use opengl && target="linux-gl"
+ cd ${S}/src/build
+ emake OPTIMIZATIONS="${CFLAGS}" SMP="${MAKEOPTS}" ${target} \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/build/stella || die "dogamesbin failed"
+
+ insinto /etc
+ doins src/emucore/stella.pro || die "doins failed"
+
+ dohtml -r docs/
+ rm -f License.txt
+ dodoc *.txt
+ prepgamesdirs
+}