summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-14 21:40:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-14 21:40:24 +0000
commit54741ee5aa29cd56260ac003b82492a2d6ca7c62 (patch)
tree140f39b940547644c4dd3b2bdcd6d5d4c2a8cbd6 /games-emulation/xmess
parenttidy old versions (diff)
downloadhistorical-54741ee5aa29cd56260ac003b82492a2d6ca7c62.tar.gz
historical-54741ee5aa29cd56260ac003b82492a2d6ca7c62.tar.bz2
historical-54741ee5aa29cd56260ac003b82492a2d6ca7c62.zip
ver bump #38177
Diffstat (limited to 'games-emulation/xmess')
-rw-r--r--games-emulation/xmess/ChangeLog7
-rw-r--r--games-emulation/xmess/files/0.78.1-glx-fix.patch19
-rw-r--r--games-emulation/xmess/files/0.78.1-icc.patch21
-rw-r--r--games-emulation/xmess/files/digest-xmess-0.78.11
-rw-r--r--games-emulation/xmess/xmess-0.78.1.ebuild224
5 files changed, 271 insertions, 1 deletions
diff --git a/games-emulation/xmess/ChangeLog b/games-emulation/xmess/ChangeLog
index 960950281c3d..65fa3c359f58 100644
--- a/games-emulation/xmess/ChangeLog
+++ b/games-emulation/xmess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/xmess
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.8 2003/12/31 15:40:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.9 2004/01/14 21:38:52 vapier Exp $
+
+*xmess-0.78.1 (14 Jan 2004)
+
+ 14 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #38177 by Starz McCllelan.
*xmess-0.77.1 (30 Nov 2003)
diff --git a/games-emulation/xmess/files/0.78.1-glx-fix.patch b/games-emulation/xmess/files/0.78.1-glx-fix.patch
new file mode 100644
index 000000000000..20d29a9d0573
--- /dev/null
+++ b/games-emulation/xmess/files/0.78.1-glx-fix.patch
@@ -0,0 +1,19 @@
+diff -urN xmame-0.70.1-orig/src/unix/osd_cpu.h xmame-0.70.1/src/unix/osd_cpu.h
+--- xmame-0.70.1-orig/src/unix/osd_cpu.h 2003-06-12 05:37:50.000000000 +0200
++++ xmame-0.70.1/src/unix/osd_cpu.h 2003-07-15 15:09:03.000000000 +0200
+@@ -39,11 +39,15 @@
+ #endif
+
+ /* grrr work around some stupid header conflicts */
++#ifndef xgl
+ #if !defined __XF86_DGA_C && !defined __XOPENGL_C_ && !defined LONG64
+ typedef signed char INT8;
+ typedef signed short INT16;
+ typedef signed int INT32;
+ #endif
++#else
++#include <X11/Xmd.h>
++#endif
+
+ #ifndef LONG64
+ typedef signed long long INT64;
diff --git a/games-emulation/xmess/files/0.78.1-icc.patch b/games-emulation/xmess/files/0.78.1-icc.patch
new file mode 100644
index 000000000000..4e091bd550a4
--- /dev/null
+++ b/games-emulation/xmess/files/0.78.1-icc.patch
@@ -0,0 +1,21 @@
+--- Makefile 2003-12-31 10:09:34.498349816 -0500
++++ Makefile.icc 2003-12-31 10:18:46.570422104 -0500
+@@ -266,7 +266,7 @@
+ ifeq ($(CC),icc)
+
+ # Optimizations for the Intel compiler.
+- CFLAGS = -O3 -rcd -Xa -ipo -ipo_obj
++ CFLAGS = -O3 -rcd -ipo -ipo_obj -w
+
+ else
+ ifeq ($(CC),sun-forte)
+--- src/unix/osinline.h 2003-11-13 00:06:05.000000000 -0500
++++ src/unix/osinline.h.icc 2003-12-31 10:19:16.673845688 -0500
+@@ -20,6 +20,7 @@
+ #define osd_mark_vector_dirty(x,y)
+ #endif
+
++#undef X86_ASM
+ #ifdef X86_ASM
+ #define vec_mult _vec_mult
+ INLINE int _vec_mult(int x, int y)
diff --git a/games-emulation/xmess/files/digest-xmess-0.78.1 b/games-emulation/xmess/files/digest-xmess-0.78.1
new file mode 100644
index 000000000000..c2d6aab01b6d
--- /dev/null
+++ b/games-emulation/xmess/files/digest-xmess-0.78.1
@@ -0,0 +1 @@
+MD5 e92c61e0040114db3a83b7dbb7fc9449 xmame-0.78.1.tar.bz2 12148685
diff --git a/games-emulation/xmess/xmess-0.78.1.ebuild b/games-emulation/xmess/xmess-0.78.1.ebuild
new file mode 100644
index 000000000000..ae88b1f34d88
--- /dev/null
+++ b/games-emulation/xmess/xmess-0.78.1.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.78.1.ebuild,v 1.1 2004/01/14 21:38:52 vapier Exp $
+
+inherit games flag-o-matic gcc eutils
+
+TARGET=${PN}
+
+DESCRIPTION="Multiple Arcade Machine Emulator for X11"
+HOMEPAGE="http://x.mame.net/"
+SRC_URI="http://x.mame.net/download/xmame-${PV}.tar.bz2"
+
+LICENSE="xmame"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~ia64 ~amd64"
+IUSE="sdl dga xv alsa esd opengl X 3dfx svga ggi arts joystick icc net"
+
+RDEPEND="sys-libs/zlib
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ alsa? ( media-libs/alsa-lib )
+ xv? ( virtual/x11 )
+ dga? ( virtual/x11 )
+ X? ( virtual/x11 )
+ esd? ( >=media-sound/esound-0.2.29 )
+ svga? ( media-libs/svgalib )
+ ggi? ( media-libs/libggi )
+ arts? ( kde-base/arts )"
+DEPEND="${RDEPEND}
+ icc? ( dev-lang/icc )
+ x86? ( dev-lang/nasm )
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/xmame-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-glx-fix.patch
+ sed -i 's:JOY_BUTTONS 16:JOY_BUTTONS 32:' src/unix/devices.h || die "setting joybuttons failed" #36818
+
+ #ln -s makefile.unix Makefile
+ case "${ARCH}" in
+ x86|ia64|amd64)
+ sed -i \
+ -e '/X86_ASM_68000 =/s:#::' \
+ -e '/X86_MIPS3_DRC =/s:#::' Makefile \
+ || die "sed Makefile (x86) failed"
+ if [ `use joystick` ] ; then
+ sed -i \
+ -e '/JOY_I386.*=/s:#::' Makefile \
+ || die "sed Makefile (joystick) failed"
+ fi
+ ;;
+ ppc|sparc)
+ sed -i \
+ -e '/^MY_CPU/s:i386:risc:' Makefile \
+ || die "sed Makefile (ppc|sparc) failed"
+ ;;
+ alpha)
+ sed -i \
+ -e '/^MY_CPU/s:i386:alpha:' Makefile \
+ || die "sed Makefile (alpha) failed"
+ ;;
+ mips)
+ sed -i \
+ -e '/^MY_CPU/s:i386:mips:' Makefile \
+ || die "sed Makefile (mips) failed"
+ ;;
+ esac
+
+ if [ `use net` ] ; then
+ sed -i \
+ -e '/XMAME_NET/s:#::' Makefile \
+ || die "sed Makefile (net) failed"
+ if [ `use icc` ] ; then
+ ewarn "Sorry, but net support is not compatible with icc."
+ ewarn "icc support has been ignored in favor of net support."
+ fi
+ else
+ if [ `use icc` ] ; then
+ epatch ${FILESDIR}/${PV}-icc.patch
+ sed -i \
+ -e '/^CC/s:gcc:icc:' Makefile \
+ || die "sed Makefile (icc) failed"
+ fi
+ fi
+ if [ `use esd` ] ; then
+ sed -i \
+ -e '/SOUND_ESOUND/s:#::' Makefile \
+ || die "sed Makefile (esd) failed"
+ fi
+ if [ `use alsa` ] ; then
+ sed -i \
+ -e '/SOUND_ALSA/s:#::' Makefile \
+ || die "sed Makefile (alsa) failed"
+ fi
+ if [ `use arts` ] ; then
+ sed -i \
+ -e '/SOUND_ARTS/s:#::' Makefile \
+ || die "sed Makefile (arts) failed"
+ fi
+ if [ `use sdl` ] ; then
+ sed -i \
+ -e '/SOUND_SDL/s:#::' Makefile \
+ || die "sed Makefile (sdl) failed"
+ fi
+ if [ `use dga` ] ; then
+ sed -i \
+ -e '/X11_DGA/s:#::' Makefile \
+ || die "sed Makefile (dga) failed"
+ if [ `use 3dfx` ] ; then
+ sed -i \
+ -e '/TDFX_DGA_WORKAROUND/s:#::' Makefile \
+ || die "sed Makefile (dga) failed"
+ fi
+ fi
+
+ if [ `use xv` ] ; then
+ sed -i \
+ -e '/X11_XV/s:#::' Makefile \
+ || die "sed Makefile (xv) failed"
+ fi
+
+ case ${ARCH} in
+ x86) append-flags -Wno-unused -fomit-frame-pointer -fstrict-aliasing -fstrength-reduce -ffast-math
+ [ `gcc-major-version` -eq 3 ] \
+ && append-flags -falign-functions=2 -falign-jumps=2 -falign-loops=2 \
+ || append-flags -malign-functions=2 -malign-jumps=2 -malign-loops=2
+ ;;
+ ppc) append-flags -Wno-unused -funroll-loops -fstrength-reduce -fomit-frame-pointer -ffast-math -fsigned-char
+ ;;
+ esac
+ sed -i \
+ -e "/^PREFIX/s:=.*:=/usr:" \
+ -e "/^BINDIR/s:=.*:=${GAMES_BINDIR}:" \
+ -e "/^XMAMEROOT/s:=.*:=${GAMES_DATADIR}/${TARGET}:" \
+ -e "/^TARGET/s:mame:${TARGET:1}:" \
+ -e "s:^CFLAGS =:CFLAGS=${CFLAGS}:" Makefile \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ local disp=0
+ if [ `use sdl` ] ; then
+ emake -j1 DISPLAY_METHOD=SDL || die "emake failed (SDL)"
+ disp=1
+ fi
+ if [ `use svga` ] ; then
+ emake -j1 DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
+ disp=1
+ fi
+ if [ `use ggi` ] ; then
+ emake -j1 DISPLAY_METHOD=ggi || die "emake failed (ggi)"
+ disp=1
+ fi
+ if [ `use opengl` ] ; then
+ emake -j1 DISPLAY_METHOD=xgl || die "emake failed (xgl)"
+ disp=1
+ fi
+ if [ ! -z "`use X``use dga``use xv`" ] || [ ${disp} -eq 0 ] ; then
+ emake -j1 DISPLAY_METHOD=x11 || die "emake failed (x11)"
+ fi
+}
+
+src_install() {
+ sed -i \
+ -e "s:Xmame:${TARGET}:g" \
+ -e "s:xmame:${TARGET}:g" \
+ doc/*.6
+ sed -i \
+ -e "s:^PREFIX.*:PREFIX=${D}/usr:" \
+ -e "s:^BINDIR.*:BINDIR=${D}/${GAMES_BINDIR}:" \
+ -e "s:^XMAMEROOT.*:XMAMEROOT=${D}/${GAMES_DATADIR}/${TARGET}:" \
+ Makefile
+
+ local disp=0
+ if [ `use sdl` ] ; then
+ make DISPLAY_METHOD=SDL install || die "install failed (sdl)"
+ disp=1
+ fi
+ if [ `use svga` ] ; then
+ make DISPLAY_METHOD=svgalib install || die "install failed (svga)"
+ disp=1
+ fi
+ if [ `use ggi` ] ; then
+ make DISPLAY_METHOD=ggi install || die "install failed (ggi)"
+ disp=1
+ fi
+ if [ `use opengl` ] ; then
+ make DISPLAY_METHOD=xgl install || die "install failed (xgl)"
+ disp=1
+ fi
+ if [ ! -z "`use X``use dga``use xv`" ] || [ ${disp} -eq 0 ] ; then
+ make DISPLAY_METHOD=x11 install || die "install failed (x11)"
+ fi
+
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -r ctrlr ${D}/${GAMES_DATADIR}/${PN}/ || die "cp failed"
+ dodoc doc/{changes.*,*.txt,mame/*,${TARGET}rc.dist} README todo || die "dodoc failed"
+ dohtml -r doc/* || die "dohtml failed"
+
+ if [ `use opengl` ] ; then
+ dosym ${TARGET}.xgl ${GAMES_BINDIR}/${TARGET}
+ elif [ ! -z "`use X``use dga``use xv`" -o ${disp} -eq 0 ] ; then
+ dosym ${TARGET}.x11 ${GAMES_BINDIR}/${TARGET}
+ elif [ `use sdl` ] ; then
+ dosym ${TARGET}.SDL ${GAMES_BINDIR}/${TARGET}
+ elif [ `use svga` ] ; then
+ dosym ${TARGET}.svgalib ${GAMES_BINDIR}/${TARGET}
+ elif [ `use ggi` ] ; then
+ dosym ${TARGET}.ggi ${GAMES_BINDIR}/${TARGET}
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "Your available MAME binaries are: ${TARGET}"
+ [ ! -z "`use X``use dga``use xv`" ] && einfo " ${TARGET}.x11"
+ [ `use sdl` ] && einfo " ${TARGET}.SDL"
+ [ `use ggi` ] && einfo " ${TARGET}.ggi"
+ [ `use svga` ] && einfo " ${TARGET}.svgalib"
+ [ `use opengl` ] && einfo " ${TARGET}.xgl"
+}