summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-26 18:35:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-26 18:35:01 +0000
commitf541734977da74b6862af01444a29b7d2fef5470 (patch)
treecac94530980c43c7c281cc25966b5d176c008445 /games-board
parentTrim old ebuilds and patches. (diff)
downloadhistorical-f541734977da74b6862af01444a29b7d2fef5470.tar.gz
historical-f541734977da74b6862af01444a29b7d2fef5470.tar.bz2
historical-f541734977da74b6862af01444a29b7d2fef5470.zip
old
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/crafty-20.13.ebuild77
-rw-r--r--games-board/mah-jong/mah-jong-1.7.ebuild52
-rw-r--r--games-board/pioneers/files/pioneers-0.11.3-DOS.patch56
-rw-r--r--games-board/pioneers/pioneers-0.11.3-r1.ebuild37
4 files changed, 0 insertions, 222 deletions
diff --git a/games-board/crafty/crafty-20.13.ebuild b/games-board/crafty/crafty-20.13.ebuild
deleted file mode 100644
index f32cd8299447..000000000000
--- a/games-board/crafty/crafty-20.13.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-20.13.ebuild,v 1.4 2008/04/11 15:41:11 wolf31o2 Exp $
-
-inherit flag-o-matic toolchain-funcs games
-
-DESCRIPTION="Bob Hyatt's strong chess engine"
-HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
-SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip"
-
-LICENSE="crafty"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="no-opts"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/-o crafty/s/CC/CXX/' Makefile \
- || die "sed failed"
- sed -i \
- -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
- || die "sed failed"
-}
-
-src_compile() {
- local makeopts="target=LINUX"
-
- if ! use no-opts ; then
- if [[ $(tc-getCC) = icc ]] ; then
- makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
- append-flags -D_REENTRANT -tpp6 \
- -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
- -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
- -DSMP -DCPUS=4 -DCLONE -DDGT
- append-flags -O2 -fno-alias -fforce-mem \
- -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
- else
- if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
- || [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
- append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
- -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
- -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
- append-flags -fforce-mem -fno-gcse \
- -fomit-frame-pointer -mpreferred-stack-boundary=2
- makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
- else
- : # everything else :)
- fi
- fi
- fi
- append-flags -DPOSIX
- emake ${makeopts} crafty-make LDFLAGS="-lpthread" || die "build failed"
-}
-
-src_install() {
- dogamesbin crafty || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins crafty.hlp || die "doins failed"
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- elog
- elog "Note: No books or tablebases have been installed. If you want them, just"
- elog " download them from ${HOMEPAGE}."
- elog " You will find documentation there too. In most cases you take now "
- elog " your xboard compatible application, (xboard, eboard, knights) and "
- elog " just play chess against computer opponent. Have fun."
- elog
-}
diff --git a/games-board/mah-jong/mah-jong-1.7.ebuild b/games-board/mah-jong/mah-jong-1.7.ebuild
deleted file mode 100644
index a39dd3c1e0b2..000000000000
--- a/games-board/mah-jong/mah-jong-1.7.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.7.ebuild,v 1.3 2008/02/29 19:00:23 carlo Exp $
-
-inherit eutils toolchain-funcs games
-
-MY_P="mj-${PV}-src"
-DESCRIPTION="A networked Mah Jong program, together with a computer player"
-HOMEPAGE="http://www.stevens-bradfield.com/MahJong/"
-SRC_URI="http://www.stevens-bradfield.com/MahJong/Source/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND="=x11-libs/gtk+-1.2*"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i \
- -e '/^.TH/ s/1/6/' xmj.man \
- || die "sed failed"
- sed -i \
- -e "/^DESTDIR =/ s:=.*:= ${D}:" \
- -e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
- -e '/^MANDIR =/ s:man/man1:/usr/share/man/man6:' \
- -e '/^MANSUFFIX =/ s:1:6:' \
- -e "/^CC =/ s:gcc:$(tc-getCC):" \
- -e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
- -e "/^LDLIBS =/ s:$:${LDFLAGS}:" \
- -e '/^INSTPGMFLAGS =/ s:-s::' \
- -e '/^CDEBUGFLAGS =/d' \
- -e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile \
- || die "sed failed"
-}
-
-src_install() {
- emake install install.man || die "emake install failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r fallbacktiles/ tiles-numbered/ tiles-small/ || die "doins failed"
- newicon tiles-v1/tongE.xpm ${PN}.xpm
- make_desktop_entry xmj Mah-Jong ${PN}
- dodoc CHANGES ChangeLog *.txt
- prepgamesdirs
-}
diff --git a/games-board/pioneers/files/pioneers-0.11.3-DOS.patch b/games-board/pioneers/files/pioneers-0.11.3-DOS.patch
deleted file mode 100644
index d7241eddb501..000000000000
--- a/games-board/pioneers/files/pioneers-0.11.3-DOS.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Index: common/state.c
-===================================================================
---- common/state.c (revision 1355)
-+++ common/state.c (working copy)
-@@ -68,10 +68,12 @@
-
- static void route_event(StateMachine * sm, gint event)
- {
-- StateFunc curr_state;
-+ StateFunc curr_state = NULL;
- gpointer user_data;
-
-- curr_state = sm_current(sm);
-+ if (sm->stack_ptr >= 0)
-+ curr_state = sm_current(sm);
-+
- user_data = sm->user_data;
- if (user_data == NULL)
- user_data = sm;
-@@ -89,20 +91,22 @@
-
- switch (event) {
- case SM_ENTER:
-- curr_state(user_data, event);
-+ if (curr_state)
-+ curr_state(user_data, event);
- break;
- case SM_INIT:
-- curr_state(user_data, event);
-+ if (curr_state)
-+ curr_state(user_data, event);
- if (!sm->is_dead && sm->global !=NULL)
- sm->global (user_data, event);
- break;
- case SM_RECV:
- sm_cancel_prefix(sm);
-- if (curr_state(user_data, event))
-+ if (curr_state && curr_state(user_data, event))
- break;
- sm_cancel_prefix(sm);
- if (!sm->is_dead
-- && sm->global !=NULL && sm->global (user_data, event))
-+ && sm->global != NULL && sm->global (user_data, event))
- break;
-
- sm_cancel_prefix(sm);
-@@ -112,7 +116,8 @@
- case SM_NET_CLOSE:
- sm_close(sm);
- default:
-- curr_state(user_data, event);
-+ if (curr_state)
-+ curr_state(user_data, event);
- if (!sm->is_dead && sm->global !=NULL)
- sm->global (user_data, event);
- break;
diff --git a/games-board/pioneers/pioneers-0.11.3-r1.ebuild b/games-board/pioneers/pioneers-0.11.3-r1.ebuild
deleted file mode 100644
index fd2ac1790085..000000000000
--- a/games-board/pioneers/pioneers-0.11.3-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pioneers/pioneers-0.11.3-r1.ebuild,v 1.1 2007/11/20 03:09:06 mr_bones_ Exp $
-
-inherit eutils gnome2
-
-DESCRIPTION="A clone of the popular board game The Settlers of Catan"
-HOMEPAGE="http://pio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="nls"
-
-RDEPEND=">=dev-libs/glib-2.6
- >=gnome-base/libgnome-2.10
- >=x11-libs/gtk+-2.6
- >=app-text/scrollkeeper-0.3.8
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- gnome2_src_unpack
- epatch "${FILESDIR}/${P}-DOS.patch" #bug #198807
-}
-
-src_compile() {
- gnome2_src_compile $(use_enable nls)
-}
-
-src_install() {
- DOCS="AUTHORS ChangeLog README TODO NEWS" \
- gnome2_src_install scrollkeeper_localstate_dir="${D}"/var/lib/scrollkeeper/
-}