summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-14 18:13:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-14 18:13:21 +0000
commitf34e5d9369abd57b61f09dd4c3f3983da0e4192e (patch)
treede00a696016027bf0b8075f0210f76c9758bc842 /games-board/pokerth
parentVersion bump. (diff)
downloadhistorical-f34e5d9369abd57b61f09dd4c3f3983da0e4192e.tar.gz
historical-f34e5d9369abd57b61f09dd4c3f3983da0e4192e.tar.bz2
historical-f34e5d9369abd57b61f09dd4c3f3983da0e4192e.zip
Fix building with GCC 4.5 wrt #318591 by Kacper Kowalik.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'games-board/pokerth')
-rw-r--r--games-board/pokerth/ChangeLog6
-rw-r--r--games-board/pokerth/Manifest5
-rw-r--r--games-board/pokerth/files/pokerth-0.7.1-gcc45.patch105
-rw-r--r--games-board/pokerth/pokerth-0.7.1.ebuild4
4 files changed, 116 insertions, 4 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 5b0eaa380ca8..e72228ae336e 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.12 2010/05/04 05:33:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.13 2010/05/14 18:13:21 ssuominen Exp $
+
+ 14 May 2010; Samuli Suominen <ssuominen@gentoo.org> pokerth-0.7.1.ebuild,
+ +files/pokerth-0.7.1-gcc45.patch:
+ Fix building with GCC 4.5 wrt #318591 by Kacper Kowalik.
04 May 2010; Michael Sterrett <mr_bones_@gentoo.org> pokerth-0.7.1.ebuild:
Allow newer boost and steal boost-related code from wesnoth ebuild
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
index 41f63680c6bf..b87afa1a43d4 100644
--- a/games-board/pokerth/Manifest
+++ b/games-board/pokerth/Manifest
@@ -1,4 +1,5 @@
+AUX pokerth-0.7.1-gcc45.patch 5908 RMD160 f786fbfaad22b44cf41c4fe9ff63de9661ea72ff SHA1 afb4e58419009f15c87a2851e1433e5376ae6f12 SHA256 0ce1f0d4c56a7e0af5eac208283f8df4f39cce2d29048957f24750d294cf78d4
DIST PokerTH-0.7.1-src.tar.bz2 6535050 RMD160 7aca895bb07bc83f977e9147217ad50eb7adfb8a SHA1 9c0c546355d7d248aeeee371d0354bfe90150a7b SHA256 97df0eeabd11e862b23e770e87053ceac245dd082f1516be1be9e4fcae882ece
-EBUILD pokerth-0.7.1.ebuild 1768 RMD160 7bc88ce349d8fadafb068b84fc499399166f3288 SHA1 142e7c2149a8bfd80ae586849d6cb6d1e280db6f SHA256 ccef6bd58733f3f371987cd2dfc0f45587e10affd068005e2377f56df227b15a
-MISC ChangeLog 1632 RMD160 5836551f5aaaea500f0386da1788dfa16249b765 SHA1 47da3e5f1550e55e1db7bc37b5ed4ff048dffacb SHA256 289d66dd9d6926614dfbe6024ee4a33f4ca4b28826ff3cf9e9a956e4e9438689
+EBUILD pokerth-0.7.1.ebuild 1808 RMD160 0fac2fa25f841718d1903966f0644ad2ca051d4a SHA1 daa159a2e58233a194472f39cc1ad9d098a9d599 SHA256 58f7ee673c2cbd637d3a3e7fa4363df88f40d069be0819886ce91f60153213da
+MISC ChangeLog 1804 RMD160 947cccc7a3c24a455a1bb11cc61b8efe0cd55831 SHA1 88b176b3a91586a80911b1148a80ba9f226fabcd SHA256 7d080ac6b3794d1df8ab0b76ec1e9d18f522de4bb6ebf9124b05e102aac96e10
MISC metadata.xml 160 RMD160 f839c00d9f25c1f873f95ab899fb64060c1d0bf5 SHA1 08c3d180cf8dbef87e40c42a18b457516a5d7ffe SHA256 5ac0a3647e8149d52ce55d391cf1680ac52d6f0330be21c3bca4790b971b5e5d
diff --git a/games-board/pokerth/files/pokerth-0.7.1-gcc45.patch b/games-board/pokerth/files/pokerth-0.7.1-gcc45.patch
new file mode 100644
index 000000000000..612771c74cb1
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-0.7.1-gcc45.patch
@@ -0,0 +1,105 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318591
+
+--- src/gui/qt/gametable/gametableimpl.cpp
++++ src/gui/qt/gametable/gametableimpl.cpp
+@@ -811,7 +811,7 @@
+ for (it_c=currentHand->getSeatsList()->begin(); it_c!=currentHand->getSeatsList()->end(); it_c++) {
+ if((*it_c)->getMyActiveStatus()) {
+
+- if((*it_c)->getMyAvatar() == "" || !QFile::QFile(QString::fromUtf8((*it_c)->getMyAvatar().c_str())).exists()) {
++ if((*it_c)->getMyAvatar() == "" || !QFile(QString::fromUtf8((*it_c)->getMyAvatar().c_str())).exists()) {
+ playerAvatarLabelArray[(*it_c)->getMyID()]->setPixmap(QPixmap::fromImage(QImage(myGameTableStyle->getDefaultAvatar())));
+ }
+ else {
+@@ -821,7 +821,7 @@
+ else {
+ if((myStartWindow->getSession()->getGameType() == Session::GAME_TYPE_INTERNET || myStartWindow->getSession()->getGameType() == Session::GAME_TYPE_NETWORK)) {
+ if((*it_c)->getMyStayOnTableStatus() == TRUE && (*it_c)->getMyType() != PLAYER_TYPE_COMPUTER) {
+- if((*it_c)->getMyAvatar() == "" || !QFile::QFile(QString::fromUtf8((*it_c)->getMyAvatar().c_str())).exists()) {
++ if((*it_c)->getMyAvatar() == "" || !QFile(QString::fromUtf8((*it_c)->getMyAvatar().c_str())).exists()) {
+ playerAvatarLabelArray[(*it_c)->getMyID()]->setPixmap(QPixmap::fromImage(QImage(myGameTableStyle->getDefaultAvatar())), TRUE);
+ }
+ else {
+@@ -847,7 +847,7 @@
+ boost::shared_ptr<PlayerInterface> tmpPlayer = myStartWindow->getSession()->getCurrentGame()->getPlayerByUniqueId(myID);
+ if (tmpPlayer.get()) {
+
+- if(QFile::QFile(myAvatar).exists()) {
++ if(QFile(myAvatar).exists()) {
+ playerAvatarLabelArray[tmpPlayer->getMyID()]->setPixmap(myAvatar);
+ tmpPlayer->setMyAvatar(myAvatar.toUtf8().constData());
+ }
+--- src/gui/qt/gametable/log/log.cpp
++++ src/gui/qt/gametable/log/log.cpp
+@@ -54,13 +54,13 @@
+
+ if(myConfig->readConfigInt("LogOnOff")) {
+ //if write logfiles is enabled
+- if(myConfig->readConfigString("LogDir") != "" && QDir::QDir(QString::fromUtf8(myConfig->readConfigString("LogDir").c_str())).exists()) {
++ if(myConfig->readConfigString("LogDir") != "" && QDir(QString::fromUtf8(myConfig->readConfigString("LogDir").c_str())).exists()) {
+
+ myLogDir = new QDir(QString::fromUtf8(myConfig->readConfigString("LogDir").c_str()));
+ myLogFile = new QFile(myLogDir->absolutePath()+"/pokerth-log-"+QDateTime::currentDateTime().toString("yyyy-MM-dd_hh.mm.ss")+".html");
+
+ //Logo-Pixmap extrahieren
+- QPixmap::QPixmap(myAppDataPath +"gfx/gui/misc/logoChip3D.png").save(myLogDir->absolutePath()+"/logo.png");
++ QPixmap(myAppDataPath +"gfx/gui/misc/logoChip3D.png").save(myLogDir->absolutePath()+"/logo.png");
+
+ // myW->textBrowser_Log->append(myLogFile->fileName());
+
+--- src/gui/qt/gamelobbydialog/gamelobbydialogimpl.cpp
++++ src/gui/qt/gamelobbydialog/gamelobbydialogimpl.cpp
+@@ -716,7 +716,7 @@
+ if(mySession->getAvatarFile(playerInfo.avatar, myAvatarFileName)) {
+
+ QString myAvatarString(QString::fromUtf8(myAvatarFileName.c_str()));
+- if(QFile::QFile(myAvatarString).exists()) {
++ if(QFile(myAvatarString).exists()) {
+
+ QPixmap myAvatarPixmap(25,26);
+ myAvatarPixmap.fill(Qt::transparent);
+--- src/gui/qt/settingsdialog/selectavatardialog/selectavatardialogimpl.cpp
++++ src/gui/qt/settingsdialog/selectavatardialog/selectavatardialogimpl.cpp
+@@ -212,7 +212,7 @@
+ else return QString("");
+ }
+
+- if(groupBox_2->isChecked() && QFile::QFile(lineEdit->text()).exists() ) return externalAvatar;
++ if(groupBox_2->isChecked() && QFile(lineEdit->text()).exists() ) return externalAvatar;
+ else return QString("");
+ }
+
+@@ -232,9 +232,9 @@
+ }
+
+ if(groupBox_2->isChecked()) {
+- if(QFile::QFile(lineEdit->text()).exists()) {
++ if(QFile(lineEdit->text()).exists()) {
+
+- if(QFile::QFile(lineEdit->text()).size() <= 30720 ) {
++ if(QFile(lineEdit->text()).size() <= 30720 ) {
+ externalAvatar = lineEdit->text();
+ settingsCorrect = TRUE;
+ }
+--- src/gui/qt/settingsdialog/settingsdialogimpl.cpp
++++ src/gui/qt/settingsdialog/settingsdialogimpl.cpp
+@@ -559,7 +559,7 @@
+ myConfig->writeConfigInt("FlipsideOwn", radioButton_flipsideOwn->isChecked());
+
+ if(radioButton_flipsideOwn->isChecked()) {
+- if(QFile::QFile(lineEdit_OwnFlipsideFilename->text()).exists() && lineEdit_OwnFlipsideFilename->text() != "") {myConfig->writeConfigString("FlipsideOwnFile", lineEdit_OwnFlipsideFilename->text().toUtf8().constData()); }
++ if(QFile(lineEdit_OwnFlipsideFilename->text()).exists() && lineEdit_OwnFlipsideFilename->text() != "") {myConfig->writeConfigString("FlipsideOwnFile", lineEdit_OwnFlipsideFilename->text().toUtf8().constData()); }
+ else { QMessageBox::warning(this, tr("Settings Error"),
+ tr("The entered flipside picture doesn't exist.\n"
+ "Please enter an valid picture!"),
+@@ -615,7 +615,7 @@
+ myConfig->writeConfigInt("LogOnOff", groupBox_logOnOff->isChecked());
+ if (myConfig->readConfigInt("LogOnOff")) {
+ // if log On
+- if(QDir::QDir(lineEdit_logDir->text()).exists() && lineEdit_logDir->text() != "") { myConfig->writeConfigString("LogDir", lineEdit_logDir->text().toUtf8().constData()); }
++ if(QDir(lineEdit_logDir->text()).exists() && lineEdit_logDir->text() != "") { myConfig->writeConfigString("LogDir", lineEdit_logDir->text().toUtf8().constData()); }
+ else {
+ QMessageBox::warning(this, tr("Settings Error"),
+ tr("The log file directory doesn't exist.\n"
diff --git a/games-board/pokerth/pokerth-0.7.1.ebuild b/games-board/pokerth/pokerth-0.7.1.ebuild
index a5c4bec3982c..cc7199f80f19 100644
--- a/games-board/pokerth/pokerth-0.7.1.ebuild
+++ b/games-board/pokerth/pokerth-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.7.1.ebuild,v 1.6 2010/05/04 05:33:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.7.1.ebuild,v 1.7 2010/05/14 18:13:21 ssuominen Exp $
EAPI=2
inherit multilib flag-o-matic eutils qt4 games
@@ -29,6 +29,8 @@ DEPEND=">=dev-libs/boost-1.39
S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+
local boost_ver
if use dedicated ; then