summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-03 01:52:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-03 01:52:57 +0000
commit2f55daad04bde5286f32306d53eb24fb3e52d469 (patch)
tree37ed60cd6c2fbe86420966687f869d1ba987ea7a /games-board/pokerth
parentFix broken Manifest for gnulib-9999-r1.ebuild. (diff)
downloadhistorical-2f55daad04bde5286f32306d53eb24fb3e52d469.tar.gz
historical-2f55daad04bde5286f32306d53eb24fb3e52d469.tar.bz2
historical-2f55daad04bde5286f32306d53eb24fb3e52d469.zip
initial commit (bug #169238)
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.28.1 i686
Diffstat (limited to 'games-board/pokerth')
-rw-r--r--games-board/pokerth/ChangeLog10
-rw-r--r--games-board/pokerth/Manifest4
-rw-r--r--games-board/pokerth/metadata.xml5
-rw-r--r--games-board/pokerth/pokerth-0.6.3.ebuild54
4 files changed, 73 insertions, 0 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
new file mode 100644
index 000000000000..dd9d3c74ccb3
--- /dev/null
+++ b/games-board/pokerth/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-board/pokerth
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.1 2009/02/03 01:52:57 mr_bones_ Exp $
+
+*pokerth-0.6.3 (03 Feb 2009)
+
+ 03 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +pokerth-0.6.3.ebuild:
+ initial commit (bug #169238)
+
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
new file mode 100644
index 000000000000..c6b3019f2fc9
--- /dev/null
+++ b/games-board/pokerth/Manifest
@@ -0,0 +1,4 @@
+DIST PokerTH-0.6.3-2-src.tar.bz2 4644455 RMD160 bc1d96c934e1aef645568457bd1941b8751cf372 SHA1 b3bb880f95070add6aae17160ec0ebfc80a95ac0 SHA256 d5a9f5678c09fe830770c7d60b97a9052c6eb9f41e4c8de0808323f415ac692b
+EBUILD pokerth-0.6.3.ebuild 1219 RMD160 6736e7c1cd3f47842153cf09323e3557338b694c SHA1 006decb5a47f2b215c94bd69e52c1ca6e2a18888 SHA256 78e73f40ce22b17cdf21f6bbb9550e7e3cdd4535a8555e42e7f50f7d990d3da1
+MISC ChangeLog 371 RMD160 009056fd2d22a26a1ce1384b41f775d1dcf31531 SHA1 26b57dd0052139b1fe038092be04c06aa7fe6f97 SHA256 5d0b9ae744e32595bd957ee609a05e90a4d6ac53e3dbd0da69d03d5284dce429
+MISC metadata.xml 160 RMD160 f839c00d9f25c1f873f95ab899fb64060c1d0bf5 SHA1 08c3d180cf8dbef87e40c42a18b457516a5d7ffe SHA256 5ac0a3647e8149d52ce55d391cf1680ac52d6f0330be21c3bca4790b971b5e5d
diff --git a/games-board/pokerth/metadata.xml b/games-board/pokerth/metadata.xml
new file mode 100644
index 000000000000..f72870c0c28d
--- /dev/null
+++ b/games-board/pokerth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
diff --git a/games-board/pokerth/pokerth-0.6.3.ebuild b/games-board/pokerth/pokerth-0.6.3.ebuild
new file mode 100644
index 000000000000..0f952f86e9ba
--- /dev/null
+++ b/games-board/pokerth/pokerth-0.6.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.6.3.ebuild,v 1.1 2009/02/03 01:52:57 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils qt4 games
+
+MY_P="PokerTH-${PV}-2-src"
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
+
+LICENSE="GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+DEPEND=">=dev-libs/boost-1.34.1
+ >=net-libs/gnutls-2.2.2
+ >=net-misc/curl-7.16
+ !dedicated? (
+ media-libs/libsdl
+ media-libs/sdl-mixer[mikmod,vorbis]
+ >=sys-libs/zlib-1.2.3
+ || ( x11-libs/qt-gui:4 x11-libs/qt:4 )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use dedicated ; then
+ sed -i \
+ -e 's/pokerth_game.pro//' \
+ pokerth.pro \
+ || die "sed failed"
+ fi
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dogamesbin bin/pokerth_server || die
+ if ! use dedicated ; then
+ dogamesbin ${PN} || die
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data || die
+ domenu ${PN}.desktop
+ doicon ${PN}.png
+ fi
+ dodoc ChangeLog TODO docs/{net_protocol,server_setup_howto}.txt
+ prepgamesdirs
+}