summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-15 21:57:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-15 21:57:45 +0000
commitbb93e3b46772bca81d2c02bb5d2331d46435c6c8 (patch)
treed2a7bb408ed35d0a1ab6aa91b2feeef149345d40 /games-arcade/rocksndiamonds
parentversion bump (diff)
downloadhistorical-bb93e3b46772bca81d2c02bb5d2331d46435c6c8.tar.gz
historical-bb93e3b46772bca81d2c02bb5d2331d46435c6c8.tar.bz2
historical-bb93e3b46772bca81d2c02bb5d2331d46435c6c8.zip
version bump
Diffstat (limited to 'games-arcade/rocksndiamonds')
-rw-r--r--games-arcade/rocksndiamonds/Manifest4
-rw-r--r--games-arcade/rocksndiamonds/files/digest-rocksndiamonds-3.0.41
-rw-r--r--games-arcade/rocksndiamonds/rocksndiamonds-3.0.4.ebuild46
3 files changed, 49 insertions, 2 deletions
diff --git a/games-arcade/rocksndiamonds/Manifest b/games-arcade/rocksndiamonds/Manifest
index e2d77bb56b63..0480685afff7 100644
--- a/games-arcade/rocksndiamonds/Manifest
+++ b/games-arcade/rocksndiamonds/Manifest
@@ -1,8 +1,8 @@
-MD5 7832971dec68a7a051229242417163fd ChangeLog 928
+MD5 e8781461112c45623a184bcdacaa1671 ChangeLog 1068
MD5 e5c437d47a7d5cbfddf821ba1d8b5057 rocksndiamonds-2.1.1.ebuild 1315
MD5 701ec42495a66162bd2ca5acb293b37c rocksndiamonds-3.0.0.ebuild 1323
MD5 e4a67da0272f9f6290fec4d6aa6efd2e rocksndiamonds-3.0.2.ebuild 1323
-MD5 e4a67da0272f9f6290fec4d6aa6efd2e rocksndiamonds-3.0.4.ebuild 1323
+MD5 e471cfe8645593eaf6cd043b8188a26b rocksndiamonds-3.0.4.ebuild 1325
MD5 819a9d015ecf8eae1ea594fadaf66255 files/digest-rocksndiamonds-2.1.1 73
MD5 f7aba7c5540abb99ed6e61d66fe9be32 files/digest-rocksndiamonds-3.0.0 73
MD5 f857790ed9e0180dd2c7a2c3685463e6 files/digest-rocksndiamonds-3.0.2 73
diff --git a/games-arcade/rocksndiamonds/files/digest-rocksndiamonds-3.0.4 b/games-arcade/rocksndiamonds/files/digest-rocksndiamonds-3.0.4
new file mode 100644
index 000000000000..ef798d64ba86
--- /dev/null
+++ b/games-arcade/rocksndiamonds/files/digest-rocksndiamonds-3.0.4
@@ -0,0 +1 @@
+MD5 42d90595c1988ba42cab02b6a11d9e75 rocksndiamonds-3.0.4.tar.gz 6827364
diff --git a/games-arcade/rocksndiamonds/rocksndiamonds-3.0.4.ebuild b/games-arcade/rocksndiamonds/rocksndiamonds-3.0.4.ebuild
new file mode 100644
index 000000000000..abcde7675e7b
--- /dev/null
+++ b/games-arcade/rocksndiamonds/rocksndiamonds-3.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/rocksndiamonds-3.0.4.ebuild,v 1.1 2003/09/15 21:57:43 msterret Exp $
+
+inherit games flag-o-matic
+
+DESCRIPTION="A Boulderdash clone"
+SRC_URI="http://www.artsoft.org/RELEASES/unix/rocksndiamonds/${P}.tar.gz"
+HOMEPAGE="http://www.artsoft.org/rocksndiamonds/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND="X? ( virtual/x11 )
+ sdl? ( >=media-libs/libsdl-1.2.3
+ >=media-libs/sdl-mixer-1.2.4
+ >=media-libs/sdl-image-1.2.2 )
+ || ( X? ( ) sdl? ( ) virtual/x11 )"
+
+src_compile() {
+ replace-flags -march=k6 -march=i586
+
+ local makeopts="RO_GAME_DIR=${GAMES_DATADIR}/${PN} RW_GAME_DIR=${GAMES_STATEDIR}/${PN}"
+ if [ `use X` ] || [ -z "`use X``use sdl`" ] ; then
+ make clean || die
+ make ${makeopts} OPTIONS="${CFLAGS}" x11 || die
+ mv rocksndiamonds{,.x11}
+ fi
+ if [ `use sdl` ] ; then
+ make clean || die
+ make ${makeopts} OPTIONS="${CFLAGS}" sdl || die
+ mv rocksndiamonds{,.sdl}
+ fi
+}
+
+src_install() {
+ dogamesbin rocksndiamonds.{sdl,x11}
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -R graphics levels music sounds ${D}/${GAMES_DATADIR}/${PN}/
+
+ newman rocksndiamonds.{1,6}
+ dodoc CHANGES CREDITS HARDWARE README TODO docs/elements/*.txt
+
+ prepgamesdirs
+}