summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-30 19:25:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-30 19:25:50 +0000
commitaa33f4a0e0405e1fc70e5412a740ba9e961bdea6 (patch)
tree10fdc579cb07aa08b6bcdfff7bdbf2668d04ffb0 /games-action
parentold (diff)
downloadhistorical-aa33f4a0e0405e1fc70e5412a740ba9e961bdea6.tar.gz
historical-aa33f4a0e0405e1fc70e5412a740ba9e961bdea6.tar.bz2
historical-aa33f4a0e0405e1fc70e5412a740ba9e961bdea6.zip
initial commit - ebuild submitted by Azamat H. Hackimov via bug #294776
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'games-action')
-rw-r--r--games-action/violetland/ChangeLog10
-rw-r--r--games-action/violetland/Manifest4
-rw-r--r--games-action/violetland/metadata.xml5
-rw-r--r--games-action/violetland/violetland-0.2.4.ebuild49
4 files changed, 68 insertions, 0 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
new file mode 100644
index 000000000000..ad996f776ee0
--- /dev/null
+++ b/games-action/violetland/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/violetland
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.1 2009/11/30 19:25:50 mr_bones_ Exp $
+
+*violetland-0.2.4 (30 Nov 2009)
+
+ 30 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +violetland-0.2.4.ebuild, +metadata.xml:
+ initial commit - ebuild submitted by Azamat H. Hackimov via bug #294776
+
diff --git a/games-action/violetland/Manifest b/games-action/violetland/Manifest
new file mode 100644
index 000000000000..54a75e398c8d
--- /dev/null
+++ b/games-action/violetland/Manifest
@@ -0,0 +1,4 @@
+DIST violetland-v0.2.4-src.zip 7657490 RMD160 6f42c49f8a91710510c00b94ab01dce2801028a6 SHA1 329f4123e9cbb34f0c882fa19334c96e71a0ad5c SHA256 95a9a5e0c268c0d210532bb4bcd7ad732a41d41ff82c492246a14780df51c035
+EBUILD violetland-0.2.4.ebuild 1229 RMD160 a801f2854f5aba8fc99a7d56de1bde606b76fbe4 SHA1 b5d295849b4f4fd381e0235a0f0fc28cb5d7e0f3 SHA256 3dd34d54a206f8236be0fe565d7597e813ed7399ce85c50b9a308488e6267205
+MISC ChangeLog 428 RMD160 5d8286d9978bc9e525c37e84f386b2b3f8544d17 SHA1 d0a54c984e92f4296469ac9644c0b8bf552233d2 SHA256 44a69c1b0777dab4a6f310e2390bdf0cd7514f192eb5a00ec7f8b59df8a5c2c8
+MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-action/violetland/metadata.xml b/games-action/violetland/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/violetland/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/violetland/violetland-0.2.4.ebuild b/games-action/violetland/violetland-0.2.4.ebuild
new file mode 100644
index 000000000000..120d1f5a81dc
--- /dev/null
+++ b/games-action/violetland/violetland-0.2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.2.4.ebuild,v 1.1 2009/11/30 19:25:50 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ x11-libs/libX11
+ x11-libs/libXext
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs="\
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX} \
+ -DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ DOCS="README_EN.TXT" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}