summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-17 04:59:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-17 04:59:19 +0000
commit61f6718d7824614910ad150a61b2262babc4f816 (patch)
treea46b667c387054ac61ea1b87ce302c0d5bf14135 /games-action/bzflag/bzflag-1.10.6.20040515.ebuild
parentVersion bump #49769 by Daniel Webert. (diff)
downloadhistorical-61f6718d7824614910ad150a61b2262babc4f816.tar.gz
historical-61f6718d7824614910ad150a61b2262babc4f816.tar.bz2
historical-61f6718d7824614910ad150a61b2262babc4f816.zip
Version bump #51230 by Tupone Alfredo
Diffstat (limited to 'games-action/bzflag/bzflag-1.10.6.20040515.ebuild')
-rw-r--r--games-action/bzflag/bzflag-1.10.6.20040515.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-action/bzflag/bzflag-1.10.6.20040515.ebuild b/games-action/bzflag/bzflag-1.10.6.20040515.ebuild
new file mode 100644
index 000000000000..7cd6da56ecf9
--- /dev/null
+++ b/games-action/bzflag/bzflag-1.10.6.20040515.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-1.10.6.20040515.ebuild,v 1.1 2004/05/17 04:59:19 vapier Exp $
+
+inherit games
+
+DESCRIPTION="OpenGL accelerated 3d tank combat simulator game"
+HOMEPAGE="http://www.BZFlag.org/"
+SRC_URI="mirror://sourceforge/bzflag/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc amd64"
+IUSE=""
+
+DEPEND="virtual/opengl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:^CFLAGS=.*::' \
+ -e 's:^CXXFLAGS=.*::' \
+ -e 's:-mcpu=$host_cpu::' \
+ configure
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS README.UNIX TODO README ChangeLog BUGS PORTING
+ prepgamesdirs
+}