summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-10-29 09:54:50 +0000
committerMichał Górny <mgorny@gentoo.org>2012-10-29 09:54:50 +0000
commit05510643e9d35567d4c23bef754202ac0eeb01ac (patch)
tree73875ed68adf876211125a23a9bc0d69f0aaa412 /eclass
parentFixing useflag madness (diff)
downloadhistorical-05510643e9d35567d4c23bef754202ac0eeb01ac.tar.gz
historical-05510643e9d35567d4c23bef754202ac0eeb01ac.tar.bz2
historical-05510643e9d35567d4c23bef754202ac0eeb01ac.zip
Remove redundant "cd ${BUILD_DIR}" calls.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/distutils-r1.eclass4
2 files changed, 5 insertions, 4 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 7713ad92528d..41c6b6f18e9d 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for eclass directory
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.480 2012/10/29 09:51:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.481 2012/10/29 09:54:50 mgorny Exp $
+
+ 29 Oct 2012; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Remove redundant "cd ${BUILD_DIR}" calls.
29 Oct 2012; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass,
python-r1.eclass:
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index ca455f99329b..ba936d17641d 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.11 2012/10/29 09:51:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.12 2012/10/29 09:54:50 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -153,7 +153,6 @@ distutils-r1_python_configure() {
distutils-r1_python_compile() {
debug-print-function ${FUNCNAME} "${@}"
- cd "${BUILD_DIR}" || die
set -- "${PYTHON}" setup.py build "${@}"
echo "${@}"
"${@}" || die
@@ -217,7 +216,6 @@ distutils-r1_python_install() {
unset PYTHONDONTWRITEBYTECODE
- cd "${BUILD_DIR}" || die
set -- "${PYTHON}" setup.py install "${flags[@]}" --root="${D}" "${@}"
echo "${@}"
"${@}" || die