summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamien Krotkine <dams@gentoo.org>2004-11-29 22:47:35 +0000
committerDamien Krotkine <dams@gentoo.org>2004-11-29 22:47:35 +0000
commit88455c8b609c3b5d3da5a402e67113c3ac8aa1dc (patch)
treee3b091796e4c51da1374f369d7dfb62df57385a4 /dev-util/libconf/libconf-0.39.4.ebuild
parentadd patch (diff)
downloadhistorical-88455c8b609c3b5d3da5a402e67113c3ac8aa1dc.tar.gz
historical-88455c8b609c3b5d3da5a402e67113c3ac8aa1dc.tar.bz2
historical-88455c8b609c3b5d3da5a402e67113c3ac8aa1dc.zip
version 0.39.4
Diffstat (limited to 'dev-util/libconf/libconf-0.39.4.ebuild')
-rw-r--r--dev-util/libconf/libconf-0.39.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/libconf/libconf-0.39.4.ebuild b/dev-util/libconf/libconf-0.39.4.ebuild
new file mode 100644
index 000000000000..0e71da11d377
--- /dev/null
+++ b/dev-util/libconf/libconf-0.39.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/libconf-0.39.4.ebuild,v 1.1 2004/11/29 22:47:35 dams Exp $
+
+IUSE=""
+
+MY_P=perl-${PN/l/L}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Centralized abstraction layer for system configuration files"
+HOMEPAGE="http://libconf.net/"
+SRC_URI="http://libconf.net/download/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64 ~ppc64"
+
+DEPEND="dev-lang/perl"
+
+src_compile() {
+ emake || die "make failed"
+ make test || die "make test failed"
+}
+
+src_install() {
+ einstall PREFIX=${D}/usr
+ dodoc AUTHORS COPYING ChangeLog
+}