summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-01-26 20:51:13 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-01-26 20:51:13 +0000
commit6579d637d51323b4f2441163a33927f0e41a3821 (patch)
tree89c4d17d5e8659e07dbd840dea2bbee4a27d78db /dev-util/crash
parentRevision bump to fix bug #345725. Thanks to Ben Sagal for reporting. (diff)
downloadhistorical-6579d637d51323b4f2441163a33927f0e41a3821.tar.gz
historical-6579d637d51323b4f2441163a33927f0e41a3821.tar.bz2
historical-6579d637d51323b4f2441163a33927f0e41a3821.zip
Add the Red Hat crash analyzer utility
Package-Manager: portage-2.1.9.35/cvs/Linux x86_64
Diffstat (limited to 'dev-util/crash')
-rw-r--r--dev-util/crash/ChangeLog10
-rw-r--r--dev-util/crash/Manifest5
-rw-r--r--dev-util/crash/crash-5.1.1.ebuild23
-rw-r--r--dev-util/crash/files/crash-5.1.1-install-fix.patch12
-rw-r--r--dev-util/crash/metadata.xml17
5 files changed, 67 insertions, 0 deletions
diff --git a/dev-util/crash/ChangeLog b/dev-util/crash/ChangeLog
new file mode 100644
index 000000000000..b98926ec52e1
--- /dev/null
+++ b/dev-util/crash/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/crash
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/crash/ChangeLog,v 1.1 2011/01/26 20:51:13 cardoe Exp $
+
+*crash-5.1.1 (26 Jan 2011)
+
+ 26 Jan 2011; Doug Goldstein <cardoe@gentoo.org> +crash-5.1.1.ebuild,
+ +files/crash-5.1.1-install-fix.patch:
+ Add the Red Hat crash analyzer utility
+
diff --git a/dev-util/crash/Manifest b/dev-util/crash/Manifest
new file mode 100644
index 000000000000..110b9b470476
--- /dev/null
+++ b/dev-util/crash/Manifest
@@ -0,0 +1,5 @@
+AUX crash-5.1.1-install-fix.patch 469 RMD160 5c30c1f0a9a090ee5e23d5aeaa11c5f7dcf5688b SHA1 352a28e7c36586c13d4326a25c4a5ff226057161 SHA256 52a8b9badccb10288080617bbb7ec22c99b7d17d8f352f7ff65c21a02c8310e7
+DIST crash-5.1.1.tar.gz 24368565 RMD160 3b86cc1eaf24e777760958d02e25a80d44d2bc2a SHA1 22815fab52b901623b2fd204ad24bc81bc2608e7 SHA256 a1605a661cb9cd52e4dac416f9a8dea62a60af0b0655aa1d78ffd7b7b3679fb7
+EBUILD crash-5.1.1.ebuild 602 RMD160 d27e1e8cb1ceface5938b8786d6d2d3306c2ab82 SHA1 092018661331da23a10ca71578759419e0a427a1 SHA256 9f3faf5b3be869a03088b3b8ca2f1745bc413ae3ed2823253f159d9c99c32868
+MISC ChangeLog 382 RMD160 11fdc8e6c87d8cf99f1c3023e5febc4e777b41e7 SHA1 17bb57a9c48e2c1b3f868e2b51f9ea8f5183211f SHA256 a9ad0a910c1752f9e3ba7348e996aee528481c8c84a4f44a4b2105a30ba43352
+MISC metadata.xml 656 RMD160 8c2f2d0d89d4cc222fcd25621404a3fe51fabf7d SHA1 e04a952797dfa39a69a3ab6de4d8dd781b1776a7 SHA256 43cf659926459d3e4bd9905cd38d98932fa75dddfd6c5be5e08d40d5c9698de1
diff --git a/dev-util/crash/crash-5.1.1.ebuild b/dev-util/crash/crash-5.1.1.ebuild
new file mode 100644
index 000000000000..760429ee4130
--- /dev/null
+++ b/dev-util/crash/crash-5.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/crash/crash-5.1.1.ebuild,v 1.1 2011/01/26 20:51:13 cardoe Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Red Hat crash utility. Used for analyzing kernel core dumps"
+HOMEPAGE="http://people.redhat.com/anderson/"
+SRC_URI="http://people.redhat.com/anderson/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install-fix.patch
+}
diff --git a/dev-util/crash/files/crash-5.1.1-install-fix.patch b/dev-util/crash/files/crash-5.1.1-install-fix.patch
new file mode 100644
index 000000000000..98b86759361d
--- /dev/null
+++ b/dev-util/crash/files/crash-5.1.1-install-fix.patch
@@ -0,0 +1,12 @@
+diff -Nur crash-5.1.1/Makefile crash-5.1.1-fixes//Makefile
+--- crash-5.1.1/Makefile 2010-12-23 12:59:44.000000000 -0600
++++ crash-5.1.1-fixes//Makefile 2011-01-26 13:17:11.000000000 -0600
+@@ -322,7 +322,7 @@
+ cc -c ${CRASH_CFLAGS} build_data.c ${WARNING_OPTIONS} ${WARNING_ERROR}
+
+ install:
+- /usr/bin/install ${PROGRAM} ${INSTALLDIR}
++ /usr/bin/install -D ${PROGRAM} ${INSTALLDIR}/${PROGRAM}
+ # /usr/bin/install ${PROGRAM}d ${INSTALLDIR}
+
+ unconfig: make_configure
diff --git a/dev-util/crash/metadata.xml b/dev-util/crash/metadata.xml
new file mode 100644
index 000000000000..c172a8fd9074
--- /dev/null
+++ b/dev-util/crash/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Red Hat crash analysis utility is loosely based on the SVR4 UNIX
+ crash command, but has been significantly enhanced by completely merging
+ it with the GNU gdb debugger. The marriage of the two effectively
+ combines the kernel-specific nature of the traditional UNIX crash
+ utility with the source code level debugging capabilities of gdb.
+ </longdescription>
+</pkgmetadata>
+