summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2009-02-24 21:09:56 +0000
committerAli Polatel <hawking@gentoo.org>2009-02-24 21:09:56 +0000
commit10b8f131daeaf5c10a20fa053ef6b0a5df0b93bd (patch)
treeda1d855add6cbaeb3d778ca057d53d54a7370fb1 /dev-util/buildbot
parentVersion bump. src_test added. (diff)
downloadhistorical-10b8f131daeaf5c10a20fa053ef6b0a5df0b93bd.tar.gz
historical-10b8f131daeaf5c10a20fa053ef6b0a5df0b93bd.tar.bz2
historical-10b8f131daeaf5c10a20fa053ef6b0a5df0b93bd.zip
Revision bump, install contrib
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'dev-util/buildbot')
-rw-r--r--dev-util/buildbot/ChangeLog7
-rw-r--r--dev-util/buildbot/Manifest3
-rw-r--r--dev-util/buildbot/buildbot-0.7.9-r2.ebuild95
3 files changed, 103 insertions, 2 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index fbe4998d080a..c7d8ec7478e8 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.31 2009/02/15 11:53:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.32 2009/02/24 21:09:56 hawking Exp $
+
+*buildbot-0.7.9-r2 (24 Feb 2009)
+
+ 24 Feb 2009; Feed your head <alip@gentoo.org> +buildbot-0.7.9-r2.ebuild:
+ Revision bump, install contrib/
*buildbot-0.7.9-r1 (15 Feb 2009)
diff --git a/dev-util/buildbot/Manifest b/dev-util/buildbot/Manifest
index da46fb63f91b..45909607f1d8 100644
--- a/dev-util/buildbot/Manifest
+++ b/dev-util/buildbot/Manifest
@@ -14,6 +14,7 @@ EBUILD buildbot-0.7.7-r1.ebuild 2955 RMD160 f0b9ae03e34ee7fb12d41094d812b867cccf
EBUILD buildbot-0.7.7.ebuild 3004 RMD160 60ebe9d168b18d754a132750cdb901aa2d57df29 SHA1 b570608500590a66dbac7600dfb4352b442ab257 SHA256 7fa51ca5714bae0395a2a93f4f74499825f6af410c11eea5d48e13e839e68641
EBUILD buildbot-0.7.8.ebuild 2983 RMD160 599abb057709948ef01897a927a6391560d99452 SHA1 8e17f202002370444f530fc1402e0086567cad45 SHA256 896329a1d23077d923e0aea6e6211429d8b6e271256692a116ce83fbd96c70ff
EBUILD buildbot-0.7.9-r1.ebuild 3019 RMD160 644edfd71e5a51d2f2e421bb013f2d9cd234b2df SHA1 53ce490657e49a2b57f5720dbc2068a02ad1ddcb SHA256 6e3a4b82090979a132fd2fea12243074b41d0ecf2e31212c5e96a6b2f5057763
+EBUILD buildbot-0.7.9-r2.ebuild 3037 RMD160 fc57dea372714f2cfefd682051ea5610b1f409e9 SHA1 d6fb8ece70ad6ff02aa0aa11f307d315111553ff SHA256 9c62c218d6fc8214e0513b31641deb4545e111b75adc944ca19bd3298d37f483
EBUILD buildbot-0.7.9.ebuild 3004 RMD160 b16dc8ce50cffd86b018cab7438d195289b81d3d SHA1 5ccd7143effd2e56c8125d720de7c88527afbc64 SHA256 907bfe2f88af84f5d888ffc26df362e344ac9fd67c5f9429c820adba035eea49
-MISC ChangeLog 4554 RMD160 5377829fd7585f77f1af92bd81a7c86b92bb7d33 SHA1 92aad534cb9d093279f7617b63afcb357bcc6cbd SHA256 9c9a6870aa66c6e057454f5fa0bcbee54044b73cde1177da27d92fb355e1851a
+MISC ChangeLog 4698 RMD160 d4719bd567b560f36095fbab9c37b16a633f66ac SHA1 2eabf0b562ecbce54874f76c3304aab7052202c5 SHA256 5895755fb8df4e80c89a960f6d1486efc81b04146bf8b3090adac50e6a04ef30
MISC metadata.xml 1289 RMD160 8b1f435f1f165587a3407dba213b82afd8497f0c SHA1 4287932657bc884970634f3307f72d242a36846e SHA256 6e2e6ac0d9b0ef9df0f7f92c80fb56038779fdd5edbfd312649f24c79430664e
diff --git a/dev-util/buildbot/buildbot-0.7.9-r2.ebuild b/dev-util/buildbot/buildbot-0.7.9-r2.ebuild
new file mode 100644
index 000000000000..391ffda9c293
--- /dev/null
+++ b/dev-util/buildbot/buildbot-0.7.9-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.9-r2.ebuild,v 1.1 2009/02/24 21:09:56 hawking Exp $
+
+NEED_PYTHON="2.3"
+
+inherit distutils eutils
+
+DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
+HOMEPAGE="http://buildbot.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc irc mail manhole test"
+
+CDEPEND=">=dev-python/twisted-2.0.1"
+RDEPEND="${CDEPEND}
+ mail? ( dev-python/twisted-mail )
+ manhole? ( dev-python/twisted-conch )
+ irc? ( dev-python/twisted-words )
+ dev-python/twisted-web
+ dev-python/twisted-mail"
+DEPEND="${CDEPEND}
+ test? ( dev-python/twisted-web
+ dev-python/twisted-mail )
+ doc? ( =dev-python/epydoc-2* )"
+
+pkg_setup() {
+ enewuser buildbot
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
+ die "epyrun failed"
+ fi
+}
+
+src_test() {
+ local trialopts
+ if ! has_version ">=dev-python/twisted-2.2"; then
+ trialopts=-R
+ fi
+ PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
+}
+
+src_install() {
+ distutils_src_install
+ doinfo docs/buildbot.info
+ dohtml -r docs/buildbot.html docs/images
+
+ insinto /usr/share/doc/${PF}
+ doins -r contrib
+ doins -r docs/examples
+
+ use doc && doins -r docs/reference
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave
+ newinitd "${FILESDIR}/buildbot.initd-r1" buildslave
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster
+ newinitd "${FILESDIR}/buildbot.initd-r1" buildmaster
+
+ # Make it print the right names when you start/stop the script.
+ sed -i -e 's/@buildbot@/buildslave/' \
+ "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
+ sed -i -e 's/@buildbot@/buildmaster/' \
+ "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
+}
+
+pkg_postinst() {
+ elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
+ elog "scripts were added to support starting buildbot through gentoo's"
+ elog "init system. To use this set up your build master or build slave"
+ elog "following the buildbot documentation, make sure the resulting"
+ elog 'directories are owned by the "buildbot" user and point'
+ elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
+ elog "at the right location. The scripts can run as a different user"
+ elog "if desired. If you need to run more than one master or slave"
+ elog "just copy the scripts."
+ elog ""
+ elog "Upstream recommends the following when upgrading:"
+ elog "Each time you install a new version of Buildbot, you should run the new"
+ elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
+ elog "This will add files and fix (or at least detect) incompatibilities between"
+ elog "your old config and the new code."
+}