summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-12-13 14:07:47 +0000
committerMike Auty <ikelos@gentoo.org>2009-12-13 14:07:47 +0000
commit68d682dd8fd2d1d8833ea976d90aaf8c36c6ce51 (patch)
tree10c80a12bda233fe609888e28f2d5007a63a6427 /dev-util/bless/bless-0.6.0-r1.ebuild
parentAdd -j1 to build (bug #288191); also make sure that if install fails the ebui... (diff)
downloadhistorical-68d682dd8fd2d1d8833ea976d90aaf8c36c6ce51.tar.gz
historical-68d682dd8fd2d1d8833ea976d90aaf8c36c6ce51.tar.bz2
historical-68d682dd8fd2d1d8833ea976d90aaf8c36c6ce51.zip
Fix up documentation bug 296669 and an upstream bug affecting nvidia users.
Package-Manager: portage-2.2_rc56/cvs/Linux i686
Diffstat (limited to 'dev-util/bless/bless-0.6.0-r1.ebuild')
-rw-r--r--dev-util/bless/bless-0.6.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/bless/bless-0.6.0-r1.ebuild b/dev-util/bless/bless-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..1e66810f4e35
--- /dev/null
+++ b/dev-util/bless/bless-0.6.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bless/bless-0.6.0-r1.ebuild,v 1.1 2009/12/13 14:07:47 ikelos Exp $
+
+EAPI=2
+
+inherit autotools eutils gnome2 mono
+
+DESCRIPTION="GTK# Hex Editor"
+HOMEPAGE="http://home.gna.org/bless/"
+SRC_URI="http://download.gna.org/bless/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/mono-1.1.14
+ >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/glade-sharp-2.12"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=sys-devel/gettext-0.15
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-unix-specific $(use_enable debug)"
+
+ # Stolen from enlightenment.eclass
+ cp $(type -p gettextize) "${T}/" || die "Could not copy gettextize"
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
+}
+
+src_prepare() {
+ einfo "Running gettextize -f --no-changelog..."
+ ( "${T}/gettextize" -f --no-changelog > /dev/null ) || die "gettexize failed"
+ epatch "${FILESDIR}/${P}-pixmap.patch"
+ epatch "${FILESDIR}/${P}-docpath.patch"
+ eautoreconf
+}