summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-01-04 15:54:25 +0000
committerMamoru Komachi <usata@gentoo.org>2004-01-04 15:54:25 +0000
commit31b1b7c561f1aa246267c833320eac11d775d92a (patch)
tree40a904e3cf1bb7cc1abaf9a14e591f6d3a417035 /dev-tex
parentInitial import. Required by latex-unicode, see bug #17282 (diff)
downloadhistorical-31b1b7c561f1aa246267c833320eac11d775d92a.tar.gz
historical-31b1b7c561f1aa246267c833320eac11d775d92a.tar.bz2
historical-31b1b7c561f1aa246267c833320eac11d775d92a.zip
Initial import. Required by latex-unicode, see bug #17282
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/cjk-latex/Manifest5
-rw-r--r--dev-tex/cjk-latex/cjk-latex-4.5.2.ebuild133
-rw-r--r--dev-tex/cjk-latex/files/digest-cjk-latex-4.5.23
-rw-r--r--dev-tex/cjk-latex/metadata.xml6
4 files changed, 145 insertions, 2 deletions
diff --git a/dev-tex/cjk-latex/Manifest b/dev-tex/cjk-latex/Manifest
index 8783581009a5..602699f0b9be 100644
--- a/dev-tex/cjk-latex/Manifest
+++ b/dev-tex/cjk-latex/Manifest
@@ -1,3 +1,4 @@
-MD5 f4fac0831aa8f490f1e9d84c581dcfb5 cjk-latex-4.5.2.ebuild 2117
-MD5 280603881f675b24696d9cb5b395bc66 files/digest-latex-cjk-4.5.2 127
+MD5 f3315b3ff4617afbe48999f0a8fdc791 cjk-latex-4.5.2.ebuild 2974
+MD5 a43370bbb57cb967dbffe1a084475550 metadata.xml 181
+MD5 9bd98af12d183aec9ab0b4b6811cf004 ChangeLog 381
MD5 bce404cf625a0441206f78ea6d06f189 files/digest-cjk-latex-4.5.2 184
diff --git a/dev-tex/cjk-latex/cjk-latex-4.5.2.ebuild b/dev-tex/cjk-latex/cjk-latex-4.5.2.ebuild
new file mode 100644
index 000000000000..ac0294372350
--- /dev/null
+++ b/dev-tex/cjk-latex/cjk-latex-4.5.2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cjk-latex/cjk-latex-4.5.2.ebuild,v 1.1 2004/01/04 15:54:16 usata Exp $
+
+IUSE="doc emacs"
+
+inherit latex-package elisp-common
+
+MY_P="${P/-latex/}"
+
+DESCRIPTION="A LaTeX 2e macro package which enables the use of CJK scripts in various encodings"
+HOMEPAGE="http://cjk.ffii.org/"
+SRC_URI="ftp://ftp.ffii.org/pub/cjk/${MY_P}.tar.gz
+ ftp://ftp.ctan.org/tex-archive/fonts/CJK.tar.gz
+ doc? ( ftp://ftp.ffii.org/pub/cjk/${MY_P}-doc.tar.gz )"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/tetex
+ emacs? ( virtual/emacs )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+
+ unpack ${MY_P}.tar.gz
+ use doc && unpack ${MY_P}-doc.tar.gz
+
+ cd ${S}
+ unpack CJK.tar.gz
+ rm CJK/han*.300.tar.gz || die
+ for f in ${S}/CJK/*.tar.gz; do
+ tar --no-same-owner -xzf $f || die
+ find texmf/fonts/hbf -type f -exec cp {} ${T} \; || die
+ done
+ sed -i -e "/^pk_files/s/no/yes/" \
+ -e "/^dpi_x/s/300/500/" \
+ texmf/hbf2gf/*.cfg || die
+}
+
+src_compile() {
+
+ cd utils
+ for d in *conv; do
+ cd $d
+ local f=`echo $d | tr '[:upper:]' '[:lower:]'`
+ ${CC} ${CFLAGS} -o $f $f.c || die
+ if [ $d = CEFconv ] ; then
+ ${CC} ${CFLAGS} -o cef5conv cef5conv.c || die
+ ${CC} ${CFLAGS} -o cefsconv cefsconv.c || die
+ fi
+ cd -
+ done
+ cd hbf2gf
+ econf --with-kpathsea-lib=/usr/lib \
+ --with-kpathsea-include=/usr/include/kpathsea || die
+ make || die
+ cd -
+
+ if [ "`use emacs`" ] ; then
+ cd lisp
+ elisp-compile *.el
+ cd emacs-20.3
+ elisp-compile *.el
+ fi
+
+ cd ${T}
+
+ for f in ${S}/texmf/hbf2gf/*.cfg ; do
+ env HBF_TARGET=${S}/texmf/fonts ${S}/utils/hbf2gf/hbf2gf $f || die
+ done
+ for gf in *.gf ; do
+ gftopk $gf || die
+ done
+}
+
+src_install() {
+
+ cd utils
+ for d in *conv; do
+ cd $d
+ local f=`echo $d | tr '[:upper:]' '[:lower:]'`
+ dobin *latex *conv
+ doman *.1
+ cd -
+ done
+ cd hbf2gf
+ einstall || die
+
+ cd ${S}
+ dodir ${TEXMF}/tex/latex/${PN}
+ cp -a texinput/* ${D}/${TEXMF}/tex/latex/${PN} || die
+ cp -a contrib/wadalab ${D}/${TEXMF}/tex/latex/${PN} || die
+
+ if [ "`use emacs`" ] ; then
+ cd utils/lisp
+ elisp-install ${PN} *.el{,c} emacs-20.3/*.el{,c}
+ cd -
+ fi
+
+ cd ${S}
+ for d in texmf/fonts/pk/modeless/*/* ; do
+ insinto /usr/share/${d}
+ for f in ${T}/${d##*/}*.pk ; do
+ newins $f `basename ${f/.pk/.500pk}` \
+ || die "newins failed"
+ done
+ done
+ cp -a texmf/fonts/* ${D}/${TEXMF}/fonts || die "cp failed"
+
+ dodoc ChangeLog README doc/*
+ docinto chinese; dodoc doc/chinese/*
+ docinto japanese; dodoc doc/japanese/*
+ if [ "`use doc`" ] ; then
+ docinto cjk; dodoc doc/cjk/*
+ insinto /usr/share/doc/${P}/dvi
+ doins doc/dvi/*
+ insinto /usr/share/doc/${P}/ps
+ doins doc/ps/*
+ fi
+
+ docinto examples; dodoc examples/*
+ if [ "`use doc`" ] ; then
+ docinto examples/cjk; dodoc examples/cjk/*
+ insinto /usr/share/doc/${P}/examples/dvi
+ doins examples/dvi/*
+ insinto /usr/share/doc/${P}/examples/ps
+ doins examples/ps/*
+ fi
+}
diff --git a/dev-tex/cjk-latex/files/digest-cjk-latex-4.5.2 b/dev-tex/cjk-latex/files/digest-cjk-latex-4.5.2
new file mode 100644
index 000000000000..c7fa040950da
--- /dev/null
+++ b/dev-tex/cjk-latex/files/digest-cjk-latex-4.5.2
@@ -0,0 +1,3 @@
+MD5 c3ffc4a8719ba2f0a050e53bd4f400f8 cjk-4.5.2.tar.gz 435805
+MD5 c5a2105f8cfbbc2d727db5662eef0a00 CJK.tar.gz 20387840
+MD5 c08fc8fd3a4234ea42191eedb9848f8c cjk-4.5.2-doc.tar.gz 2210829
diff --git a/dev-tex/cjk-latex/metadata.xml b/dev-tex/cjk-latex/metadata.xml
new file mode 100644
index 000000000000..3a525bc0e09e
--- /dev/null
+++ b/dev-tex/cjk-latex/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>text-markup</herd>
+<herd>cjk</herd>
+</pkgmetadata>