summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-04-09 00:39:58 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-04-09 00:39:58 +0000
commit551f9306c0883e72af15bf90bb9dd914fa096979 (patch)
tree0ff2d51167685a1d87d1ddacd133e099c94d199d /dev-scheme/hop/hop-2.0.1.ebuild
parentApply patch to kdelibs to fix hang caused in dolphin when accessing network f... (diff)
downloadhistorical-551f9306c0883e72af15bf90bb9dd914fa096979.tar.gz
historical-551f9306c0883e72af15bf90bb9dd914fa096979.tar.bz2
historical-551f9306c0883e72af15bf90bb9dd914fa096979.zip
Version bump to latest upstream stable 2.0.1. Clean up hop-1.*. Added init.d/conf.d scripts.
Package-Manager: portage-2.2_rc67/cvs/Linux i686
Diffstat (limited to 'dev-scheme/hop/hop-2.0.1.ebuild')
-rw-r--r--dev-scheme/hop/hop-2.0.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-scheme/hop/hop-2.0.1.ebuild b/dev-scheme/hop/hop-2.0.1.ebuild
new file mode 100644
index 000000000000..04c61ebc543b
--- /dev/null
+++ b/dev-scheme/hop/hop-2.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/hop-2.0.1.ebuild,v 1.1 2010/04/09 00:39:57 chiiph Exp $
+
+EAPI="2"
+
+inherit multilib eutils
+
+DESCRIPTION="Hop is a higher-order language for programming interactive web applications"
+HOMEPAGE="http://hop.inria.fr/"
+SRC_URI="ftp://ftp-sop.inria.fr/indes/fp/Hop/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-scheme/bigloo-3.3a[ssl?,threads?]"
+
+RDEPEND="${DEPEND}"
+
+IUSE="ssl threads debug"
+
+pkg_setup() {
+ enewgroup hop
+ enewuser hop -1 -1 /var/lib/hop hop
+}
+
+src_configure() {
+ # Hop doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --libdir=/usr/$(get_libdir) \
+ --etcdir=/etc/hop \
+ $(use_enable ssl) \
+ $(use_enable threads) \
+ $(use debug && echo "--debug") \
+ || die "configure failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ newinitd "${FILESDIR}/hop.initd" hop || die
+ newconfd "${FILESDIR}/hop.confd" hop || die
+}