summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-01-17 15:19:00 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-01-17 15:19:00 +0000
commit507409afcfcf3ff8573648af676283b07ca9c799 (patch)
tree95f77408fb620270f83f88522dd782c415aba366 /dev-scheme/elk/elk-3.99.7.ebuild
parentRemove unneeded patch. (diff)
downloadhistorical-507409afcfcf3ff8573648af676283b07ca9c799.tar.gz
historical-507409afcfcf3ff8573648af676283b07ca9c799.tar.bz2
historical-507409afcfcf3ff8573648af676283b07ca9c799.zip
Initial ebuild. Thanks to Ales Najmann <ales.najmann@gmail.com>
Package-Manager: portage-2.1.2
Diffstat (limited to 'dev-scheme/elk/elk-3.99.7.ebuild')
-rw-r--r--dev-scheme/elk/elk-3.99.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-scheme/elk/elk-3.99.7.ebuild b/dev-scheme/elk/elk-3.99.7.ebuild
new file mode 100644
index 000000000000..af5750d816b9
--- /dev/null
+++ b/dev-scheme/elk/elk-3.99.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/elk/elk-3.99.7.ebuild,v 1.1 2007/01/17 15:19:00 hkbst Exp $
+
+DESCRIPTION="Scheme implementation designed to be embeddable extension to C/C++ applications"
+HOMEPAGE="http://sam.zoy.org/elk"
+SRC_URI="http://sam.zoy.org/elk/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ econf
+
+ # parallel build is broken
+ emake -j1 || die "Make failed!"
+}
+
+# tests are run automatically during make and fail with default src_test
+src_test() {
+ vecho "Tests already run during compile"
+}
+
+src_install() {
+ # parallel install is broken
+ emake -j1 DESTDIR="${D}" install || die "Install failed"
+}