summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-02 10:14:05 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-02 10:14:05 +0000
commitfa69980137c3236edaf2b2f3141f5d654b9b1328 (patch)
treea818ed6866e34e36f36d4f2a406c45b9c27dff0b /dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2-r1.ebuild
parentDo not depend on gconf unconditionally (diff)
downloadhistorical-fa69980137c3236edaf2b2f3141f5d654b9b1328.tar.gz
historical-fa69980137c3236edaf2b2f3141f5d654b9b1328.tar.bz2
historical-fa69980137c3236edaf2b2f3141f5d654b9b1328.zip
Create stable candidate.
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2-r1.ebuild')
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2-r1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..b7423b377fd5
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2-r1.ebuild,v 1.1 2015/01/02 10:12:11 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}