summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-28 12:15:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-28 12:15:33 +0000
commit70596247b23d43af85ac97edb90ae446f9486fd5 (patch)
treef3f88952ab66473ff190a6e0eeb4226025b41e1f /dev-ruby/rcov
parentVersion bump. (diff)
downloadhistorical-70596247b23d43af85ac97edb90ae446f9486fd5.tar.gz
historical-70596247b23d43af85ac97edb90ae446f9486fd5.tar.bz2
historical-70596247b23d43af85ac97edb90ae446f9486fd5.zip
Version bump, enable tests (even though they fail right now — reported upstream).
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rcov')
-rw-r--r--dev-ruby/rcov/ChangeLog8
-rw-r--r--dev-ruby/rcov/rcov-0.9.7.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/rcov/ChangeLog b/dev-ruby/rcov/ChangeLog
index 620012e45e4d..311c262382ee 100644
--- a/dev-ruby/rcov/ChangeLog
+++ b/dev-ruby/rcov/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rcov
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.9 2009/12/25 15:24:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.10 2009/12/28 12:15:33 flameeyes Exp $
+
+*rcov-0.9.7 (28 Dec 2009)
+
+ 28 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> +rcov-0.9.7.ebuild:
+ Version bump, enable tests (even though they fail right now — reported
+ upstream).
*rcov-0.9.6-r1 (25 Dec 2009)
diff --git a/dev-ruby/rcov/rcov-0.9.7.ebuild b/dev-ruby/rcov/rcov-0.9.7.ebuild
new file mode 100644
index 000000000000..730e1f243ee8
--- /dev/null
+++ b/dev-ruby/rcov/rcov-0.9.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.7.ebuild,v 1.1 2009/12/28 12:15:33 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="THANKS BLURB"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby code coverage analysis tool"
+HOMEPAGE="http://eigenclass.org/hiki.rb?rcov"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# TODO: both emacs and vim support are present in this package, they
+# should probably be added to the ebuild as well.
+IUSE=""
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake ext/rcovrt/rcovrt.so || die "build failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/rcovrt/rcovrt.so lib/rcovrt.so
+ fi
+}