summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-30 20:13:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-30 20:13:50 +0000
commit14fe42beccb7a49b5051c9e9b595922e061694ee (patch)
tree29940227f1bdab5810f93b916051f9c3881db30b /dev-ruby/rack/rack-1.0.1-r1.ebuild
parentVersion bump. (diff)
downloadhistorical-14fe42beccb7a49b5051c9e9b595922e061694ee.tar.gz
historical-14fe42beccb7a49b5051c9e9b595922e061694ee.tar.bz2
historical-14fe42beccb7a49b5051c9e9b595922e061694ee.zip
Add patch to fix one issue with Ruby 1.9 (tempfile behaviour); also apply to 1.0.1 even though that does not work with 1.9 at all.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rack/rack-1.0.1-r1.ebuild')
-rw-r--r--dev-ruby/rack/rack-1.0.1-r1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-ruby/rack/rack-1.0.1-r1.ebuild b/dev-ruby/rack/rack-1.0.1-r1.ebuild
index 9e8f1b353e6e..b98498897e18 100644
--- a/dev-ruby/rack/rack-1.0.1-r1.ebuild
+++ b/dev-ruby/rack/rack-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.0.1-r1.ebuild,v 1.9 2010/01/17 19:39:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.0.1-r1.ebuild,v 1.10 2010/04/30 20:13:50 flameeyes Exp $
EAPI="2"
USE_RUBY="ruby18 jruby"
@@ -23,13 +23,11 @@ IUSE=""
# make them dependencies at all.
ruby_add_bdepend test dev-ruby/test-spec
+#USE_RUBY=ruby19 \
+# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
+
all_ruby_prepare() {
- # Disable the test on the content-length: it not only varies on
- # the internal implementation (and thus “needs change often” as
- # the code says), but it also varies on the implementation (thus
- # failing on JRuby).
- sed -i -e '/content_length\.should\.be/s:^:#:' \
- test/spec_rack_mock.rb || die
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
each_ruby_test() {