summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 12:27:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 12:27:41 +0000
commit73435dc98eae12eb8e477f23bd7303a6195fbc03 (patch)
tree12d028299cc18437c94ef5a9d39764d80a47e7f4 /dev-ruby/rack-protection
parentFix deps, use fdo-mime for desktop update (diff)
downloadhistorical-73435dc98eae12eb8e477f23bd7303a6195fbc03.tar.gz
historical-73435dc98eae12eb8e477f23bd7303a6195fbc03.tar.bz2
historical-73435dc98eae12eb8e477f23bd7303a6195fbc03.zip
Initial import.
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/ChangeLog10
-rw-r--r--dev-ruby/rack-protection/Manifest14
-rw-r--r--dev-ruby/rack-protection/metadata.xml9
-rw-r--r--dev-ruby/rack-protection/rack-protection-1.1.4.ebuild23
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/ChangeLog b/dev-ruby/rack-protection/ChangeLog
new file mode 100644
index 000000000000..d651edb71fe9
--- /dev/null
+++ b/dev-ruby/rack-protection/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/rack-protection
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/ChangeLog,v 1.1 2011/12/28 12:27:41 graaff Exp $
+
+*rack-protection-1.1.4 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org>
+ +rack-protection-1.1.4.ebuild, +metadata.xml:
+ Initial import.
+
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
new file mode 100644
index 000000000000..6b08b5c74082
--- /dev/null
+++ b/dev-ruby/rack-protection/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST rack-protection-1.1.4.gem 13312 RMD160 ee4fbbafc8ce87152235ddc3206483bffaa5f1e6 SHA1 9056591c69715c4aea5ed806df6661789ea374e9 SHA256 fe2599a6e9dcfd6f45c80cba1c499d921ee99ad202bd86c39f958420f9b50003
+EBUILD rack-protection-1.1.4.ebuild 686 RMD160 c5301e8b49a1e1d3a0aae1261bfdf0e8e6ef09b8 SHA1 f6ecd83d2da179b55620fe79e8b4f6211003c5d1 SHA256 f9dfd8750b1ca68c7c772c5b02ef6b73e3caa0d50afdf3b55a023d0874a522e7
+MISC ChangeLog 376 RMD160 702facd76d247b6fd95ae05bdb0d2896558863c8 SHA1 33797253d7c0018cf89a77ed0f7436bbbacfea38 SHA256 391c8fb8a85795aa0765bd0ac316cf57f6f28aa97d9c7eedc938a2931aa57559
+MISC metadata.xml 298 RMD160 346a19f2ad30420333de0e18f6885d39c45199f9 SHA1 aa0efe5a5420481faf50930f7e9934fdce3f15f3 SHA256 4433420c9bacb25a180e376175271d9fa41ab158ac71638fb8cccc460370899b
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk77C0IACgkQiIP6VqMIqNd+5wD5AUQqSGO+Gcfw3pm0NEnTki3V
+5B3T2twQORu4G+Gf+QoA/0sAte2uO1Bn3mlGUe5vg/pZgfJiaCH/F+9t/Mh6nnOx
+=3Igp
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/rack-protection/metadata.xml b/dev-ruby/rack-protection/metadata.xml
new file mode 100644
index 000000000000..9fdeb09b3746
--- /dev/null
+++ b/dev-ruby/rack-protection/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<longdescription>
+Rack provides a common API for connecting web frameworks, web servers and layers
+of software inbetween.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/rack-protection/rack-protection-1.1.4.ebuild b/dev-ruby/rack-protection/rack-protection-1.1.4.ebuild
new file mode 100644
index 000000000000..f9f04d227f52
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-1.1.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/rack-protection-1.1.4.ebuild,v 1.1 2011/12/28 12:27:41 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rack-protection.gemspec"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks."
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test dev-ruby/rspec:2 )"