summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-24 19:01:54 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-24 19:01:54 +0000
commit0e09e2a16e2498aede557a5b6a979295b87f2801 (patch)
tree3cdbb9141882c75f9f2e3f7965b54bee08f52617 /dev-ruby/patron
parentBackport version bump from python overlay. Requested by Arfrever (diff)
downloadhistorical-0e09e2a16e2498aede557a5b6a979295b87f2801.tar.gz
historical-0e09e2a16e2498aede557a5b6a979295b87f2801.tar.bz2
historical-0e09e2a16e2498aede557a5b6a979295b87f2801.zip
Version bump.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/ChangeLog7
-rw-r--r--dev-ruby/patron/patron-0.4.12.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
index cbc3ecc422c4..ede8497b6d4e 100644
--- a/dev-ruby/patron/ChangeLog
+++ b/dev-ruby/patron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/patron
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.13 2011/04/22 17:31:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.14 2011/06/24 19:01:54 graaff Exp $
+
+*patron-0.4.12 (24 Jun 2011)
+
+ 24 Jun 2011; Hans de Graaff <graaff@gentoo.org> +patron-0.4.12.ebuild:
+ Version bump.
22 Apr 2011; Hans de Graaff <graaff@gentoo.org> -patron-0.4.10.ebuild:
Remove old version.
diff --git a/dev-ruby/patron/patron-0.4.12.ebuild b/dev-ruby/patron/patron-0.4.12.ebuild
new file mode 100644
index 000000000000..324303b54b78
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.12.ebuild,v 1.1 2011/06/24 19:01:54 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+DEPEND="${DEPEND} net-misc/curl"
+RDEPEND="${RDEPEND} net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron || die
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}