summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-13 06:38:38 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-13 06:38:38 +0000
commit34361e98e3a94cc1e2f6c2124d4d646f2333fd99 (patch)
tree30d664bf05c429da0e6f5a258641b16f78add79d /dev-ruby/oauth
parentRemove old version. (diff)
downloadhistorical-34361e98e3a94cc1e2f6c2124d4d646f2333fd99.tar.gz
historical-34361e98e3a94cc1e2f6c2124d4d646f2333fd99.tar.bz2
historical-34361e98e3a94cc1e2f6c2124d4d646f2333fd99.zip
Remove old versions.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/ChangeLog6
-rw-r--r--dev-ruby/oauth/files/oauth-0.3.6-newgem.patch27
-rw-r--r--dev-ruby/oauth/oauth-0.3.6-r1.ebuild34
-rw-r--r--dev-ruby/oauth/oauth-0.3.6.ebuild18
4 files changed, 5 insertions, 80 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index 586a20ec5f89..9b73254c2e08 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/oauth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.9 2010/06/25 21:04:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.10 2010/08/13 06:38:37 graaff Exp $
+
+ 13 Aug 2010; Hans de Graaff <graaff@gentoo.org> -oauth-0.3.6.ebuild,
+ -oauth-0.3.6-r1.ebuild, -files/oauth-0.3.6-newgem.patch:
+ Remove old versions.
*oauth-0.4.1 (25 Jun 2010)
diff --git a/dev-ruby/oauth/files/oauth-0.3.6-newgem.patch b/dev-ruby/oauth/files/oauth-0.3.6-newgem.patch
deleted file mode 100644
index d10136c0bfeb..000000000000
--- a/dev-ruby/oauth/files/oauth-0.3.6-newgem.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Patch out newgem since we don't need it to install and it currently
-isn't available in Gentoo.
-
---- Rakefile.orig 2010-02-25 07:56:59.000000000 +0100
-+++ Rakefile 2010-02-25 07:56:28.000000000 +0100
-@@ -1,4 +1,4 @@
--%w[rubygems rake rake/clean fileutils newgem rubigen hoe].each { |f| require f }
-+%w[rubygems rake rake/clean fileutils rubigen hoe].each { |f| require f }
- $LOAD_PATH << File.dirname(__FILE__) + '/lib'
- require 'oauth'
- require 'oauth/version'
-@@ -18,7 +18,6 @@
- ['ruby-hmac','>= 0.3.1']
- ]
- p.extra_dev_deps = [
-- ['newgem', ">= #{::Newgem::VERSION}"],
- ['actionpack'],
- ['rack']
- ]
-@@ -29,7 +28,6 @@
- p.rsync_args = '-av --delete --ignore-errors'
- end
-
--require 'newgem/tasks' # load /tasks/*.rake
- Dir['tasks/**/*.rake'].each { |t| load t }
-
- # TODO - want other tests/tasks run by default? Add them to the list
diff --git a/dev-ruby/oauth/oauth-0.3.6-r1.ebuild b/dev-ruby/oauth/oauth-0.3.6-r1.ebuild
deleted file mode 100644
index 36ebbfa880b1..000000000000
--- a/dev-ruby/oauth/oauth-0.3.6-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.3.6-r1.ebuild,v 1.2 2010/05/22 15:32:19 flameeyes Exp $
-
-EAPI="2"
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc TODO"
-
-RUBY_FAKEGEM_EXTRAINSTALL="script"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A RubyGem for implementing both OAuth clients and servers."
-HOMEPAGE="http://oauth.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RUBY_PATCHES=( "oauth-0.3.6-newgem.patch" )
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-ruby_add_rdepend ">=dev-ruby/ruby-hmac-0.3.1 dev-ruby/rubigen"
-
-all_ruby_prepare() {
- # Remove test that requires an insecure version of actionpack
- # http://github.com/mojodna/oauth/issues/#issue/12
- rm -f test/test_action_controller_request_proxy.rb || die "Unable to remove failing test."
-}
diff --git a/dev-ruby/oauth/oauth-0.3.6.ebuild b/dev-ruby/oauth/oauth-0.3.6.ebuild
deleted file mode 100644
index 2375d0833d3e..000000000000
--- a/dev-ruby/oauth/oauth-0.3.6.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.3.6.ebuild,v 1.1 2009/09/20 07:27:25 graaff Exp $
-
-inherit gems
-
-DESCRIPTION="A RubyGem for implementing both OAuth clients and servers."
-HOMEPAGE="http://rubyforge.org/projects/oauth/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-USE_RUBY="ruby18"
-
-DEPEND=">=dev-ruby/ruby-hmac-0.3.1"
-RDEPEND="${DEPEND}"