summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-14 07:42:15 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-14 07:42:15 +0000
commitb40adaef2b3f1e2c084542867f613273977cab7d (patch)
tree4720b0d50a131b315922c08b4ac4e37f15ca7bc4 /dev-ruby/narray/narray-0.6.0.1.ebuild
parent2.1 also stable on x86 for older kernels... bug 338420 (diff)
downloadhistorical-b40adaef2b3f1e2c084542867f613273977cab7d.tar.gz
historical-b40adaef2b3f1e2c084542867f613273977cab7d.tar.bz2
historical-b40adaef2b3f1e2c084542867f613273977cab7d.zip
Version bump.
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/narray/narray-0.6.0.1.ebuild')
-rw-r--r--dev-ruby/narray/narray-0.6.0.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/narray/narray-0.6.0.1.ebuild b/dev-ruby/narray/narray-0.6.0.1.ebuild
new file mode 100644
index 000000000000..3a323c0626a9
--- /dev/null
+++ b/dev-ruby/narray/narray-0.6.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.1.ebuild,v 1.1 2011/09/14 07:42:15 graaff Exp $
+
+EAPI=4
+
+# jruby → native extension
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.en README.ja SPEC.en SPEC.ja"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="mirror://rubyforge/${PN}/${P/_/}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those ad
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
+ cp -l ${PN}$(get_modname) lib || die "copy of ${PN}$(get_modname) failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ # Skip over the FFTW test because it needs a package we don't
+ # have in tree.
+ [[ ${unit} == test/testfftw.rb ]] && continue
+
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}