summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-08 12:46:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-08 12:46:09 +0000
commit6cda3ea7425b7edce0a3658db8b755d012bbac03 (patch)
treec913478d0b8b019e19afbf8f31b91a53e134c89f /dev-ruby/file-tail
parentVersion bump; this version requires the latest test-unit-2 with the new scrip... (diff)
downloadhistorical-6cda3ea7425b7edce0a3658db8b755d012bbac03.tar.gz
historical-6cda3ea7425b7edce0a3658db8b755d012bbac03.tar.bz2
historical-6cda3ea7425b7edce0a3658db8b755d012bbac03.zip
Version bump and remove old.
Package-Manager: portage-2.2.0_alpha116/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/file-tail')
-rw-r--r--dev-ruby/file-tail/ChangeLog9
-rw-r--r--dev-ruby/file-tail/file-tail-1.0.10.ebuild30
-rw-r--r--dev-ruby/file-tail/file-tail-1.0.6.ebuild33
3 files changed, 37 insertions, 35 deletions
diff --git a/dev-ruby/file-tail/ChangeLog b/dev-ruby/file-tail/ChangeLog
index df4232a5e140..5ce40b37fff5 100644
--- a/dev-ruby/file-tail/ChangeLog
+++ b/dev-ruby/file-tail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/file-tail
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.5 2012/01/14 08:28:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.6 2012/07/08 12:46:09 flameeyes Exp $
+
+*file-tail-1.0.10 (08 Jul 2012)
+
+ 08 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +file-tail-1.0.10.ebuild,
+ -file-tail-1.0.6.ebuild:
+ Version bump and remove old.
*file-tail-1.0.8 (14 Jan 2012)
@@ -24,4 +30,3 @@
28 Oct 2010; Hans de Graaff <graaff@gentoo.org> +file-tail-1.0.5.ebuild,
+metadata.xml:
Initial import. New dependency of www-apache/passenger.
-
diff --git a/dev-ruby/file-tail/file-tail-1.0.10.ebuild b/dev-ruby/file-tail/file-tail-1.0.10.ebuild
new file mode 100644
index 000000000000..1013b7f74ae5
--- /dev/null
+++ b/dev-ruby/file-tail/file-tail-1.0.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.10.ebuild,v 1.1 2012/07/08 12:46:09 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small ruby library that allows it to 'tail' files in Ruby"
+HOMEPAGE="http://flori.github.com/file-tail"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.4.3"
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}
diff --git a/dev-ruby/file-tail/file-tail-1.0.6.ebuild b/dev-ruby/file-tail/file-tail-1.0.6.ebuild
deleted file mode 100644
index 05098831470e..000000000000
--- a/dev-ruby/file-tail/file-tail-1.0.6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.6.ebuild,v 1.1 2011/06/25 07:15:40 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A small ruby library that allows it to 'tail' files in Ruby"
-HOMEPAGE="http://flori.github.com/file-tail"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/spruz-0.2"
-ruby_add_bdepend "test? ( virtual/ruby-test-unit ) "
-
-all_ruby_prepare() {
- # sdoc is not yet available
- sed -i -e 's/sdoc/rdoc/' Rakefile || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib tests/test_file-tail*.rb || die
-}