summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-03-28 23:36:45 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-03-28 23:36:45 +0000
commit5976b5e922fdb70c2e3c7b361a809ee35654cda3 (patch)
treea9bd66c9cebca3cee7aea88bda7d8e1ef891248c /dev-ruby/IceRuby
parentVersion bump, bump to EAPI=2 for use dep (diff)
downloadhistorical-5976b5e922fdb70c2e3c7b361a809ee35654cda3.tar.gz
historical-5976b5e922fdb70c2e3c7b361a809ee35654cda3.tar.bz2
historical-5976b5e922fdb70c2e3c7b361a809ee35654cda3.zip
Version bump
Package-Manager: portage-2.1.6.9/cvs/Linux i686
Diffstat (limited to 'dev-ruby/IceRuby')
-rw-r--r--dev-ruby/IceRuby/ChangeLog10
-rw-r--r--dev-ruby/IceRuby/IceRuby-3.3.1.ebuild61
-rw-r--r--dev-ruby/IceRuby/Manifest5
-rw-r--r--dev-ruby/IceRuby/files/IceRuby-3.3.1-Makefile.patch93
4 files changed, 166 insertions, 3 deletions
diff --git a/dev-ruby/IceRuby/ChangeLog b/dev-ruby/IceRuby/ChangeLog
index 7c8ceb0d4704..72ebfdfe3527 100644
--- a/dev-ruby/IceRuby/ChangeLog
+++ b/dev-ruby/IceRuby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/IceRuby
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/ChangeLog,v 1.14 2008/05/21 18:12:04 caleb Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/ChangeLog,v 1.15 2009/03/28 23:36:45 caleb Exp $
+
+*IceRuby-3.3.1 (28 Mar 2009)
+
+ 28 Mar 2009; Caleb Tennis <caleb@gentoo.org>
+ +files/IceRuby-3.3.1-Makefile.patch, +IceRuby-3.3.1.ebuild:
+ Version bump
*IceRuby-3.3.0 (21 May 2008)
diff --git a/dev-ruby/IceRuby/IceRuby-3.3.1.ebuild b/dev-ruby/IceRuby/IceRuby-3.3.1.ebuild
new file mode 100644
index 000000000000..e886da97ee6c
--- /dev/null
+++ b/dev-ruby/IceRuby/IceRuby-3.3.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/IceRuby-3.3.1.ebuild,v 1.1 2009/03/28 23:36:45 caleb Exp $
+
+inherit eutils
+
+MY_P=${P/Ruby/}
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.3/${MY_P}.tar.gz"
+
+S=${WORKDIR}/${MY_P}/rb
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="test debug"
+
+RDEPEND="~dev-cpp/Ice-3.3.1
+ >=dev-lang/ruby-1.8.6"
+
+DEPEND="${RDEPEND}
+ test? ( >=dev-lang/python-2.4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+
+ MAKE_RULES="${S}/config/Make.rules"
+
+ mkdir -p "${S}/bin"
+ mkdir -p "${S}/lib"
+
+ cp /usr/bin/slice2rb "${S}"/../cpp/bin
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" "${MAKE_RULES}" \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ "${MAKE_RULES}" || die "Failed to remove debug"
+ fi
+
+# sed -i -e \
+# "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+# "${MAKE_RULES}.Linux" || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+ make depend
+ emake || die "Died during make"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install Failed!"
+}
diff --git a/dev-ruby/IceRuby/Manifest b/dev-ruby/IceRuby/Manifest
index d1c537ab967e..ffdb43822e65 100644
--- a/dev-ruby/IceRuby/Manifest
+++ b/dev-ruby/IceRuby/Manifest
@@ -1,11 +1,14 @@
AUX IceRuby-3.2.1-Makefile.patch 3791 RMD160 79346934cbfc081a366d6f530737d3f8a1421ea0 SHA1 67adbd6c16761ac01a2efb1152c5efe053b9aaa1 SHA256 42b613deac59ca0c2245ffeab1c0f11380d3eb1f9b398c983506c123a7e09bc4
AUX IceRuby-3.2.1-ice_type.patch 348 RMD160 2258ec6787dd001eadc1ca8151129ccd7604e15e SHA1 962364e79eba172e63c96fd12a5a7c8f1617e32d SHA256 25b71b3d56ccc1400ac6a46bbf87f643c8a5f33525d77263818b999d164a5ac0
AUX IceRuby-3.3.0-Makefile.patch 3248 RMD160 274f6595e1dcce9618290b33d6f50501d973566b SHA1 48b32b8e692dea645d750d9bd5693a3ab976d53b SHA256 9dc4869f08b94f52dab9a0387700f57865f56fd4103626d52b21a78f1c19c87f
+AUX IceRuby-3.3.1-Makefile.patch 3248 RMD160 274f6595e1dcce9618290b33d6f50501d973566b SHA1 48b32b8e692dea645d750d9bd5693a3ab976d53b SHA256 9dc4869f08b94f52dab9a0387700f57865f56fd4103626d52b21a78f1c19c87f
AUX testing-Makefile.patch 965 RMD160 57c750a551c1ae5ca3e423ae4bd01104bb07026c SHA1 c65e561ff6453a66a9090b7721db45e5bbfc9183 SHA256 4352174e0bcb2944c1f5382e57462c70572d5d66ceaea710391daa4c73158d7f
DIST Ice-3.2.1.tar.gz 2090576 RMD160 c3394486ba13e94c2491b0dc48dc19c3e7565ecd SHA1 69fc7dbdff81d7d9300b57f6e495914f3c9e5c19 SHA256 bd24cfe0296d81e2b04ea8d97b32a4f13fdd949d0f038f4c7e0922b395075149
DIST Ice-3.3.0.tar.gz 4260675 RMD160 e85b37c93f12d9ae97c6b7b2f64f506fa051e4f8 SHA1 b599c3a4d1d3006b868bf2cbcd8e2a2d4575fb22 SHA256 73330e29799d08605d51b9fc148fdc11eb01b6c55b7e4bf4dcb8fafd98ba7749
+DIST Ice-3.3.1.tar.gz 4455154 RMD160 d64d52c35640cebe1145e62f57618473d17cbeb5 SHA1 08d0f32bdb7d909b4a531d45cccfa97bdde649aa SHA256 7b90477303ea2668e8f2cc7bb4506e3a596699e092c4e622746ea42d8286abd0
DIST IceRuby-3.2.1.tar.gz 98496 RMD160 7c852a275fe5d37bee2654889ed268022e7f1cd7 SHA1 c0e94d2957d946157494fa3cbfb05b1a5b352fe3 SHA256 319ccbf5945a9f213695c67a4bdead8605c25c0c6de926e272c4a21619ae30bf
EBUILD IceRuby-3.2.1-r1.ebuild 1859 RMD160 ab0ded1494b2657e9e18bcad5df2a28013cefb03 SHA1 6144fdce2e36533b64356b7731b8855ef71fc962 SHA256 5d4f931a8b9c300a8dfd1fdcf5f59e55b9faca17460c21b0694fd1ee23163ed0
EBUILD IceRuby-3.3.0.ebuild 1296 RMD160 5ef4e696742c023a01400b63b51171ac1266981a SHA1 431b965c8f68d9242d194fcacfdf2aaeae7a9481 SHA256 dd137f89a8e56c28863e81ccc4afefceeeee215ae2935b9d6c1ca0f887d61132
-MISC ChangeLog 2691 RMD160 08d7b33179e473ccd7f14640d64ba29972437695 SHA1 0661c6f1541c817869dfad6ae2d0b19509a7674d SHA256 3b373978ab80c7a4c041a0298c7596eacdc0270ccfdb387848ffa7e826aab43a
+EBUILD IceRuby-3.3.1.ebuild 1296 RMD160 62c6485134ab0c11502873f90f6b228cdd65bd8a SHA1 0be9efba158aa00906717c804f05d301d4787832 SHA256 9cc8fad06aef33fb06bc3d861de77d8e9726f973620685ab3514598b180e9207
+MISC ChangeLog 2846 RMD160 c326489d3ea5ead6663572514e06294ca7546718 SHA1 2aa85c92a509537b483d0e54fb0287a276d011f7 SHA256 5c945f7c4105c3082f3b13669716a286cd41eab53255160268146eecd9aa5c75
MISC metadata.xml 395 RMD160 824fce41b363dcf8701aefea3b030852c290416c SHA1 c193aaf6a87cc88495597c67ad8f913cabd9adcc SHA256 6ca761b49f13da5280c535c04facd4919a991b24fc033fa7c151e45c8acc51ee
diff --git a/dev-ruby/IceRuby/files/IceRuby-3.3.1-Makefile.patch b/dev-ruby/IceRuby/files/IceRuby-3.3.1-Makefile.patch
new file mode 100644
index 000000000000..a294395f1f57
--- /dev/null
+++ b/dev-ruby/IceRuby/files/IceRuby-3.3.1-Makefile.patch
@@ -0,0 +1,93 @@
+--- ruby/Makefile.orig 2007-03-13 08:31:21.000000000 -0400
++++ ruby/Makefile 2007-03-13 08:31:50.000000000 -0400
+@@ -128,8 +128,8 @@
+ @echo "Installing generated code"
+ @for i in $(MODULES) ; \
+ do \
+- $(INSTALL_DATA) $${i}.rb $(install_rubydir) ; \
+- $(INSTALL_DATA) -r $$i $(install_rubydir) ; \
++ $(INSTALL_DATA) $${i}.rb $(install_rubylibdir) ; \
++ $(INSTALL_DATA) -r $$i $(install_rubylibdir) ; \
+ done
+
+ clean::
+--- src/IceRuby/Makefile.orig 2007-03-13 08:31:58.000000000 -0400
++++ src/IceRuby/Makefile 2007-03-13 08:35:59.000000000 -0400
+@@ -48,6 +48,6 @@
+ ln -s $(SONAME) $@
+
+ install:: all
+- $(call installlib,$(install_libdir),$(libdir),$(LIBFILENAME),$(SONAME),$(LIBNAME))
++ $(call installlib,$(install_rubyarchdir),$(libdir),$(LIBFILENAME),$(SONAME),$(LIBNAME))
+
+ include .depend
+--- config/Make.rules.orig 2008-04-02 13:13:25.000000000 -0400
++++ config/Make.rules 2008-04-02 13:15:14.000000000 -0400
+@@ -12,13 +12,13 @@
+ # if it does not exist.
+ #
+
+-prefix ?= /opt/Ice-$(VERSION)
++prefix ?= $(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with optimization.
+@@ -45,8 +45,10 @@
+ RUBY = ruby
+ endif
+
+-RUBY_INCLUDE_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(archdir)")')
+-RUBY_LIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(libdir)")')
++RUBY_ARCH_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(archdir)")')
++RUBY_LIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(rubylibdir)")')
++RUBY_SITEARCH_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(sitearchdir)")')
++RUBY_SITELIB_DIR = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(sitelibdir)")')
+
+ RUBY_SHARED = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::MAKEFILE_CONFIG["ENABLE_SHARED"]')
+
+@@ -56,7 +58,7 @@
+ RUBY_LIB = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("-l$$(RUBY_SO_NAME)-static")')
+ endif
+
+-RUBY_FLAGS = -I$(RUBY_INCLUDE_DIR)
++RUBY_FLAGS = -I$(RUBY_ARCH_DIR)
+ RUBY_LIBS = -L$(RUBY_LIB_DIR) $(RUBY_LIB)
+
+ # ----------------------------------------------------------------------
+@@ -77,8 +79,8 @@
+ endif
+
+ libdir = $(top_srcdir)/ruby
+-install_rubydir = $(prefix)/ruby
+-install_libdir = $(prefix)/ruby
++install_rubylibdir = $(DESTDIR)/$(RUBY_SITELIB_DIR)
++install_rubyarchdir = $(DESTDIR)/$(RUBY_SITELIB_DIR)
+
+ #
+ # Platform specific definitions
+--- Makefile.orig 2008-04-23 09:17:07.000000000 -0400
++++ Makefile 2008-04-23 09:17:27.000000000 -0400
+@@ -13,11 +13,11 @@
+
+ SUBDIRS = src ruby
+
+-install:: install-common
+- @if test ! -d $(install_rubydir) ; \
++install::
++ @if test ! -d $(install_rubylibdir) ; \
+ then \
+- echo "Creating $(install_rubydir)..." ; \
+- $(call mkdir,$(install_rubydir)) ; \
++ echo "Creating $(install_rubylibdir)..." ; \
++ mkdir -p $(install_rubylibdir) ; \
+ fi
+
+ $(EVERYTHING)::
+