summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-12 08:24:27 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-12 08:24:27 +0000
commit370ebf1334c7388693818b495c0b061de58a1997 (patch)
tree43046f09e17c50438fb813300c09540d1d355404 /dev-python
parentelogin tweaks (diff)
downloadhistorical-370ebf1334c7388693818b495c0b061de58a1997.tar.gz
historical-370ebf1334c7388693818b495c0b061de58a1997.tar.bz2
historical-370ebf1334c7388693818b495c0b061de58a1997.zip
New wxPython which finally should be stably compiling with the latest
wxGtk
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxPython/ChangeLog11
-rw-r--r--dev-python/wxPython/files/digest-wxPython-2.4.0.11
-rw-r--r--dev-python/wxPython/wxPython-2.4.0.1.ebuild54
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index f7f22a426a6c..b7c514a2392d 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.14 2002/12/13 10:56:45 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.15 2003/01/12 08:24:27 raker Exp $
+
+*wxPython-2.4.0.1 (12 Jan 2003)
+
+ 12 Jan 2003; Nick Hadaway <raker@gentoo.org> wxPython-2.4.0.1.ebuild,
+ files/digest-wxPython-2.4.0.1 :
+ A much needed upgrade. Works with the latest wxGTK release.
+ As we have had much problems with the 2.3.4 wxGTK series I am hoping
+ this may actually make into the stable 1.4 release or we need to bump
+ back to to 2.3.3 series of wxGTK.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-python/wxPython/files/digest-wxPython-2.4.0.1 b/dev-python/wxPython/files/digest-wxPython-2.4.0.1
new file mode 100644
index 000000000000..d8b6ef9da352
--- /dev/null
+++ b/dev-python/wxPython/files/digest-wxPython-2.4.0.1
@@ -0,0 +1 @@
+MD5 1eb8149cb76fd2a4bf5f0c51dc08c2f4 wxPythonSrc-2.4.0.1.tar.gz 11567630
diff --git a/dev-python/wxPython/wxPython-2.4.0.1.ebuild b/dev-python/wxPython/wxPython-2.4.0.1.ebuild
new file mode 100644
index 000000000000..ee1c981d398a
--- /dev/null
+++ b/dev-python/wxPython/wxPython-2.4.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.1.ebuild,v 1.1 2003/01/12 08:24:27 raker Exp $
+
+MY_P="${P/-/Src-}"
+S="${WORKDIR}/${MY_P}/${PN}"
+DESCRIPTION="A blending of the wxWindows C++ class library with Python."
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.gz"
+HOMEPAGE="http://www.wxpython.org/"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="opengl"
+
+DEPEND=">=dev-lang/python-2.1
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ =x11-libs/wxGTK-2.4.0*
+ opengl? ( >=dev-python/PyOpenGL-2.0.0.44 )"
+
+pkg_setup() {
+ # xfree should not install these, remove until the fixed
+ # xfree is in main use.
+ rm -f /usr/X11R6/include/{zconf.h,zlib.h}
+}
+
+src_compile() {
+ # create links so the build doesnt fail
+ for d in ogl stc xrc gizmos ; do
+ ln -s ${S}/../contrib/ ${S}/contrib/${d}/contrib
+ done
+
+ #Other possible configuration variables are BUILD_OGL and BUILD_STC.
+ #BUILD_OGL builds the Object Graphics Library extension module.
+ #BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension module.
+ #Both these variable are enabled by default. To disable them set equal to zero
+ #and add to myconf.
+
+ local myconf=""
+ if [ `use opengl` ] ; then
+ myconf="${myconf} BUILD_GLCANVAS=1"
+ else
+ myconf="${myconf} BUILD_GLCANVAS=0"
+ patch -p1 < ${FILESDIR}/wxPython-2.3.3.1-noglcanvas.diff \
+ || die "patch failed"
+ fi
+
+ python setup.py ${myconf} build || die "build failed ... make sure you compiled wxGTK with all the graphic libraries enabled via USE"
+}
+
+src_install() {
+ python setup.py install --prefix=/usr --root=${D} || die
+}