summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-23 17:53:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-23 17:53:44 +0000
commitafdc035d7eb29effd3872955fb800524a3294480 (patch)
tree055b5d540822b12213b3fbbddc695014dd7d2f80 /dev-python/urwid
parentRemove virtual/libc (diff)
downloadhistorical-afdc035d7eb29effd3872955fb800524a3294480.tar.gz
historical-afdc035d7eb29effd3872955fb800524a3294480.tar.bz2
historical-afdc035d7eb29effd3872955fb800524a3294480.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-14395-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/urwid')
-rw-r--r--dev-python/urwid/ChangeLog6
-rw-r--r--dev-python/urwid/urwid-0.9.8.4.ebuild11
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 93b2b95102f7..b84fa9643bed 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.30 2009/09/06 20:33:55 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.31 2009/09/23 17:53:44 arfrever Exp $
+
+ 23 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ urwid-0.9.8.4.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
06 Sep 2009; Christian Ruppert <idl0r@gentoo.org>
-files/urwid-0.9.6-nosetuptools.diff:
diff --git a/dev-python/urwid/urwid-0.9.8.4.ebuild b/dev-python/urwid/urwid-0.9.8.4.ebuild
index 4ae87e3f5278..113da3f61869 100644
--- a/dev-python/urwid/urwid-0.9.8.4.ebuild
+++ b/dev-python/urwid/urwid-0.9.8.4.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.8.4.ebuild,v 1.4 2009/08/23 00:22:17 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.8.4.ebuild,v 1.5 2009/09/23 17:53:44 arfrever Exp $
-NEED_PYTHON=2.2
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -17,9 +18,13 @@ IUSE="examples"
DEPEND="dev-python/setuptools"
RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
src_test() {
- "${python}" test_urwid.py || die "unit tests failed"
+ testing() {
+ "$(PYTHON)" test_urwid.py
+ }
+ python_execute_function testing
}
src_install() {