summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 03:07:56 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 03:07:56 +0000
commit9b9e0b2fb3be5f797c37470e96389055a4ce1309 (patch)
tree0a2f9a8238b4900f922a87ac144849302cc43071 /dev-python/twisted-cvs
parentgcc3.3 patch (diff)
downloadhistorical-9b9e0b2fb3be5f797c37470e96389055a4ce1309.tar.gz
historical-9b9e0b2fb3be5f797c37470e96389055a4ce1309.tar.bz2
historical-9b9e0b2fb3be5f797c37470e96389055a4ce1309.zip
fix license/repoman
Diffstat (limited to 'dev-python/twisted-cvs')
-rw-r--r--dev-python/twisted-cvs/twisted-cvs-20021104.ebuild65
1 files changed, 32 insertions, 33 deletions
diff --git a/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild b/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild
index 28ed03232c31..4eaccdb012a8 100644
--- a/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild
+++ b/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild,v 1.5 2003/06/22 12:16:00 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild,v 1.6 2003/08/07 03:03:13 vapier Exp $
ECVS_USER="anon"
ECVS_SERVER="twistedmatrix.com:/cvs"
@@ -8,51 +8,50 @@ ECVS_MODULE="Twisted"
ECVS_CVS_OPTIONS="-dP"
inherit cvs
+inherit distutils
S=${WORKDIR}/${ECVS_MODULE}
DESCRIPTION="Twisted is a framework, written in Python, for writing networked applications."
-SRC_URI=""
HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI=""
+
LICENSE="LGPL-2.1"
SLOT="0"
-RDEPEND="virtual/python"
-DEPEND="$DEPEND
- >=dev-python/epydoc-1.1
- >=dev-python/pycrypto-1.9_alpha4"
KEYWORDS="~x86 ~alpha"
-IUSE=""
-inherit distutils
+RDEPEND="virtual/python"
+DEPEND="${DEPEND}
+ >=dev-python/epydoc-1.1
+ >=dev-python/pycrypto-1.9_alpha4"
src_compile() {
- distutils_src_compile
- ## .ps & pdf generation (book) sandbox violation ..
- ##${S}/admin/process-docs
- # from admin/release-twisted
-# cd ${S}
-# epydoc -o doc/api twisted/* &&
-# cp doc/api/index.html doc/api/index.html.bak &&
-# cp doc/api/epydoc-index.html doc/api/index.html
-# tree doc/api
+ distutils_src_compile
+ ## .ps & pdf generation (book) sandbox violation ..
+ ##${S}/admin/process-docs
+ # from admin/release-twisted
+ #cd ${S}
+ #epydoc -o doc/api twisted/* &&
+ #cp doc/api/index.html doc/api/index.html.bak &&
+ #cp doc/api/epydoc-index.html doc/api/index.html
+ #tree doc/api
}
src_install() {
- distutils_src_install
-
- # next few lines will install docs: 9.4 megs!
- dodir /usr/share/doc/${PF}
- # of course it's documentation!
- doman doc/man/*.[0-9n]
- rm -rf doc/man # don't dupe the man pages
- cd doc
- cp -r . ${D}/usr/share/doc/${PF}
- cd ../
-
+ distutils_src_install
+
+ # next few lines will install docs: 9.4 megs!
+ dodir /usr/share/doc/${PF}
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+ cd doc
+ cp -r . ${D}/usr/share/doc/${PF}
+ cd ../
}
pkg_postinst() {
- echo
- einfo "This is for testing only! Do not submit bugs regarding this to"
- einfo "Bugzilla. Instead mail me at lordvan@gentoo.org"
- echo
+ echo
+ einfo "This is for testing only! Do not submit bugs regarding this to"
+ einfo "Bugzilla. Instead mail me at lordvan@gentoo.org"
+ echo
}