summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2003-10-13 19:22:02 +0000
committerChris PeBenito <pebenito@gentoo.org>2003-10-13 19:22:02 +0000
commit9d7c0ac58be946f887c8eb49184e211af79277d4 (patch)
tree0d4be3b1ce3323b421542057353c01ac2dd96cab /dev-python/python-selinux
parentAdded ~sparc keyword. (diff)
downloadhistorical-9d7c0ac58be946f887c8eb49184e211af79277d4.tar.gz
historical-9d7c0ac58be946f887c8eb49184e211af79277d4.tar.bz2
historical-9d7c0ac58be946f887c8eb49184e211af79277d4.zip
Make the ebuild fail if the compile fails.
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog5
-rw-r--r--dev-python/python-selinux/Manifest6
-rw-r--r--dev-python/python-selinux/python-selinux-2.7.ebuild4
3 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index 2931dc753637..a0a3769ddd45 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.7 2003/10/13 05:50:27 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.8 2003/10/13 19:22:00 pebenito Exp $
+
+ 13 Oct 2003; Chris PeBenito <pebenito@gentoo.org> python-selinux-2.7.ebuild:
+ Make the ebuild fail if the compile fails.
*python-selinux-2.7 (13 Oct 2003)
diff --git a/dev-python/python-selinux/Manifest b/dev-python/python-selinux/Manifest
index 01a26d287968..965192b67b07 100644
--- a/dev-python/python-selinux/Manifest
+++ b/dev-python/python-selinux/Manifest
@@ -1,6 +1,6 @@
-MD5 e010d713dec1a57d7ae150ce2090cf62 python-selinux-1.2.ebuild 721
-MD5 6f6b48ed49474dbfca86c0493798939f python-selinux-2.7.ebuild 702
-MD5 1c9540a758963848aacefb19725dc767 ChangeLog 1498
+MD5 acc8efc807972e662f4db62757e89d2e ChangeLog 1625
MD5 c998c579cfc08c6860f78304a67cfce9 metadata.xml 525
+MD5 e010d713dec1a57d7ae150ce2090cf62 python-selinux-1.2.ebuild 721
+MD5 21405a804b580372b82749671741c1a8 python-selinux-2.7.ebuild 711
MD5 fe5e6d65ff52bce9f7de7629920c3644 files/digest-python-selinux-1.2 69
MD5 87a8f1b6a61967117d4f1617c65fa6c9 files/digest-python-selinux-2.7 69
diff --git a/dev-python/python-selinux/python-selinux-2.7.ebuild b/dev-python/python-selinux/python-selinux-2.7.ebuild
index ec4cef13bb74..2799c6da6843 100644
--- a/dev-python/python-selinux/python-selinux-2.7.ebuild
+++ b/dev-python/python-selinux/python-selinux-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.7.ebuild,v 1.1 2003/10/13 05:50:27 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.7.ebuild,v 1.2 2003/10/13 19:22:00 pebenito Exp $
DESCRIPTION="Python bindings for SELinux functions"
HOMEPAGE="http://selinux.dev.gentoo.org/python"
@@ -18,7 +18,7 @@ S=${WORKDIR}/${PN}
src_compile() {
cd ${S}
- gcc -shared -o selinux.so -I /usr/include/python2.2/ selinux.c -lselinux
+ gcc -shared -o selinux.so -I /usr/include/python2.2/ selinux.c -lselinux || die
}
src_install() {