summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-09 09:26:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-09 09:26:53 +0000
commit89256d7ce20759eb25596b0b2700ecf423472b8d (patch)
tree7b68489aba598e8fbb3d0661955efd1fd57a1110 /dev-python/python-ptrace
parentx86 stable wrt bug #400219 (diff)
downloadhistorical-89256d7ce20759eb25596b0b2700ecf423472b8d.tar.gz
historical-89256d7ce20759eb25596b0b2700ecf423472b8d.tar.bz2
historical-89256d7ce20759eb25596b0b2700ecf423472b8d.zip
Bump
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/ChangeLog9
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.4.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index a78c60727b11..91c9c3654f4e 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-ptrace
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.9 2011/11/22 21:43:27 neurogeek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.10 2012/03/09 09:24:15 patrick Exp $
+
+*python-ptrace-0.6.4 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org> +python-ptrace-0.6.4.ebuild:
+ Bump
22 Nov 2011; Jesus Rivero <neurogeek@gentoo.org>
python-ptrace-0.6.3.ebuild, -python-ptrace-0.6.3-r1.ebuild:
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.4.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.4.ebuild
new file mode 100644
index 000000000000..7a7f13ccf29f
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.6.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.4.ebuild,v 1.1 2012/03/09 09:24:15 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
+HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-libs/distorm64"
+RESTRICT_PYTHON_ABIS="2.4"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+PYTHON_MODNAME="ptrace"
+
+src_prepare() {
+ python_copy_sources
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+
+ 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
+ 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
+ }
+ python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}