summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-04-07 17:31:00 +0000
committerJon Nelson <jnelson@gentoo.org>2002-04-07 17:31:00 +0000
commit401508dabdbaadebfa420b6911fadf7ace7e9202 (patch)
treebb76547b82a8e92ce2ce954806ec5e1d96b99251 /dev-python/python-docs
parentadd tdb 1.0.6 ebuild (diff)
downloadhistorical-401508dabdbaadebfa420b6911fadf7ace7e9202.tar.gz
historical-401508dabdbaadebfa420b6911fadf7ace7e9202.tar.bz2
historical-401508dabdbaadebfa420b6911fadf7ace7e9202.zip
add python-docs for 2.2
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/python-docs-2.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-2.2.ebuild b/dev-python/python-docs/python-docs-2.2.ebuild
new file mode 100644
index 000000000000..564e170d5f6a
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer Jon Nelson <jnelson@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.2.ebuild,v 1.1 2002/04/07 17:31:00 jnelson Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTML documentation for Python"
+SRC_URI="http://www.python.org/ftp/python/doc/2.2p1/html-2.2p1.tar.bz2"
+HOMEPAGE="http://www.python.org/doc/2.2/"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+src_install() {
+ docinto html
+ cp -R ${S}/* ${D}/usr/share/doc/${P}/html
+ chown -R root.root ${D}/usr/share/doc/${P}/html
+ find ${D}/usr/share/doc/${P}/html -type d -exec chmod 0755 \{\} \;
+ find ${D}/usr/share/doc/${P}/html -type f -exec chmod 0644 \{\} \;
+}