summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-18 23:30:29 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-18 23:30:29 +0000
commit7d6c3265a49b5d4ea29c959d7f83a210742f5a3d (patch)
tree10915f8d20ab8ff36fddeb9016f5a0c316d1da72 /dev-python/pyorbit/pyorbit-2.24.0.ebuild
parentAdd gucharmap2 compatibility patch, bug #240728. Fix typoe, bug #253438. (diff)
downloadhistorical-7d6c3265a49b5d4ea29c959d7f83a210742f5a3d.tar.gz
historical-7d6c3265a49b5d4ea29c959d7f83a210742f5a3d.tar.bz2
historical-7d6c3265a49b5d4ea29c959d7f83a210742f5a3d.zip
Bump to 2.24. Bug fixes.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyorbit/pyorbit-2.24.0.ebuild')
-rw-r--r--dev-python/pyorbit/pyorbit-2.24.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyorbit/pyorbit-2.24.0.ebuild b/dev-python/pyorbit/pyorbit-2.24.0.ebuild
new file mode 100644
index 000000000000..369b5f0c6ea2
--- /dev/null
+++ b/dev-python/pyorbit/pyorbit-2.24.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/pyorbit-2.24.0.ebuild,v 1.1 2009/02/18 23:30:29 eva Exp $
+
+inherit python gnome2 multilib
+
+DESCRIPTION="ORBit2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.4
+ >=gnome-base/orbit-2.12"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
+
+src_unpack() {
+ unpack ${A}
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ python_version
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/CORBA.py \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pyorbit_CORBA.py
+
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/PortableServer.py \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pyorbit_PortableServer.py
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}