summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-02-08 17:24:43 +0000
committerMichael Januszewski <spock@gentoo.org>2010-02-08 17:24:43 +0000
commitb6dd83a804830adf12258eccb329311918055553 (patch)
tree2243feb3105bc58e3c148e93246a3279cd8fbcfe /dev-python/pycuda/pycuda-9999.ebuild
parentConvert to ruby-fakegem. (diff)
downloadhistorical-b6dd83a804830adf12258eccb329311918055553.tar.gz
historical-b6dd83a804830adf12258eccb329311918055553.tar.bz2
historical-b6dd83a804830adf12258eccb329311918055553.zip
Add the 'opengl' USE flag.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pycuda/pycuda-9999.ebuild')
-rw-r--r--dev-python/pycuda/pycuda-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/pycuda/pycuda-9999.ebuild b/dev-python/pycuda/pycuda-9999.ebuild
index f39459c94088..62c60a2b65d8 100644
--- a/dev-python/pycuda/pycuda-9999.ebuild
+++ b/dev-python/pycuda/pycuda-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-9999.ebuild,v 1.3 2010/02/08 11:43:46 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-9999.ebuild,v 1.4 2010/02/08 17:24:43 spock Exp $
# Ebuild generated by g-pypi 0.2.1 (rev. 204)
EAPI="2"
@@ -16,12 +16,13 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="examples"
+IUSE="examples opengl"
RDEPEND="=dev-python/pytools-9999
dev-libs/boost[python]
>=dev-util/nvidia-cuda-toolkit-2.0
- >=dev-python/numpy-1.0.4"
+ >=dev-python/numpy-1.0.4
+ virtual/opengl"
DEPEND="${RDEPEND}"
@@ -30,7 +31,11 @@ src_unpack() {
}
src_configure() {
- ./configure.py --cuda-root="${ROOT}opt/cuda" --boost-python-libname=boost_python-mt --boost-thread-libname=boost_thread-mt --boost-compiler=gcc
+ local myopts=""
+ use opengl && myopts="${myopts} --cuda-enable-gl"
+ ./configure.py --cuda-root="${ROOT}opt/cuda" \
+ --boost-python-libname=boost_python-mt \
+ --boost-thread-libname=boost_thread-mt --boost-compiler=gcc ${myopts}
}
src_install() {