summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-01-06 21:28:06 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-01-06 21:28:06 +0000
commit76c585daf29b998e83779ae0170c410fe0c9cc71 (patch)
tree6db642825834b9ecf85a8ea5e874fa08bceeb4c6 /dev-python/pyconstruct
parentFix dependencies (bug #381689). Patch by Arfrever. (diff)
downloadhistorical-76c585daf29b998e83779ae0170c410fe0c9cc71.tar.gz
historical-76c585daf29b998e83779ae0170c410fe0c9cc71.tar.bz2
historical-76c585daf29b998e83779ae0170c410fe0c9cc71.zip
Fix dependencies. Set PYTHON_MODNAME and use distutils_pkg_postinst() and distutils_pkg_postrm(). Patch by Arfrever.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyconstruct')
-rw-r--r--dev-python/pyconstruct/ChangeLog8
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.06.ebuild16
2 files changed, 11 insertions, 13 deletions
diff --git a/dev-python/pyconstruct/ChangeLog b/dev-python/pyconstruct/ChangeLog
index 0e1d9f8a5a5d..ab36951b74f3 100644
--- a/dev-python/pyconstruct/ChangeLog
+++ b/dev-python/pyconstruct/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyconstruct
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.4 2011/12/25 11:11:00 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.5 2012/01/06 21:28:06 hwoarang Exp $
+
+ 06 Jan 2012; Markos Chandras <hwoarang@gentoo.org> pyconstruct-2.06.ebuild:
+ Fix dependencies. Set PYTHON_MODNAME and use distutils_pkg_postinst() and
+ distutils_pkg_postrm(). Patch by Arfrever.
*pyconstruct-2.06 (25 Dec 2011)
diff --git a/dev-python/pyconstruct/pyconstruct-2.06.ebuild b/dev-python/pyconstruct/pyconstruct-2.06.ebuild
index 39f06b3dcdbe..7c8977eca70d 100644
--- a/dev-python/pyconstruct/pyconstruct-2.06.ebuild
+++ b/dev-python/pyconstruct/pyconstruct-2.06.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.06.ebuild,v 1.1 2011/12/25 11:11:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.06.ebuild,v 1.2 2012/01/06 21:28:06 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -21,12 +21,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND="app-arch/unzip
+DEPEND="dev-python/setuptools
doc? ( dev-python/sphinx )"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="construct"
+
src_compile() {
distutils_src_compile
@@ -44,11 +46,3 @@ src_install() {
dohtml -r docs/_build/html/* || die "Installation of documentation failed"
fi
}
-
-pkg_postinst() {
- python_mod_optimize construct
-}
-
-pkg_postrm() {
- python_mod_cleanup construct
-}