summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-07-26 16:08:51 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-07-26 16:08:51 +0000
commitc5f792dfcd027c8b3d392a5a64499d965d4303f9 (patch)
tree92087efd6eccbd430375a107b26e3db3ea2945a9 /dev-python/psutil
parentHOMEPAGE fix (diff)
downloadhistorical-c5f792dfcd027c8b3d392a5a64499d965d4303f9.tar.gz
historical-c5f792dfcd027c8b3d392a5a64499d965d4303f9.tar.bz2
historical-c5f792dfcd027c8b3d392a5a64499d965d4303f9.zip
HOMEPAGE and tests fix
Package-Manager: portage-2.2.0_alpha46/cvs/Linux i686
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/ChangeLog5
-rw-r--r--dev-python/psutil/psutil-0.2.1.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/psutil/ChangeLog b/dev-python/psutil/ChangeLog
index 633573f33e4b..80680609fff4 100644
--- a/dev-python/psutil/ChangeLog
+++ b/dev-python/psutil/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/psutil
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.1 2011/05/30 10:00:03 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/ChangeLog,v 1.2 2011/07/26 16:08:51 neurogeek Exp $
+
+ 26 Jul 2011; Jesus Rivero <neurogeek@gentoo.org> psutil-0.2.1.ebuild:
+ HOMEPAGE and tests fix
*psutil-0.2.1 (30 May 2011)
diff --git a/dev-python/psutil/psutil-0.2.1.ebuild b/dev-python/psutil/psutil-0.2.1.ebuild
index b1459ba82955..59a67576b25a 100644
--- a/dev-python/psutil/psutil-0.2.1.ebuild
+++ b/dev-python/psutil/psutil-0.2.1.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/psutil-0.2.1.ebuild,v 1.1 2011/05/30 10:00:03 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psutil/psutil-0.2.1.ebuild,v 1.2 2011/07/26 16:08:51 neurogeek Exp $
EAPI="3"
PYTHON_DEPEND="*"
SUPPORT_PYTHON_ABIS="1"
+PYTHON_TESTS_RESTRICTED_ABIS="3.*"
inherit distutils
DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="http://code.google.com/p/psutil/"
+HOMEPAGE="http://code.google.com/p/psutil/ http://pypi.python.org/pypi/psutil"
SRC_URI="http://psutil.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
@@ -22,9 +23,6 @@ RESTRICT="test"
src_test() {
testing() {
- # Test suite broken with Python 3
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" test/test_psutil.py
}
python_execute_function testing