summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-12-20 00:30:06 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-12-20 00:30:06 +0000
commit128495299ea324a87dcc145d9d579ba4ee8d5c95 (patch)
treec0cffc7e3b9430e8f5a9761426e675f1f3c35aac /dev-python/matplotlib
parentStable on alpha. (diff)
downloadhistorical-128495299ea324a87dcc145d9d579ba4ee8d5c95.tar.gz
historical-128495299ea324a87dcc145d9d579ba4ee8d5c95.tar.bz2
historical-128495299ea324a87dcc145d9d579ba4ee8d5c95.zip
Version bump, new ebuild by Fernando Serboncini <fserb@terra.com.br>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog8
-rw-r--r--dev-python/matplotlib/Manifest10
-rw-r--r--dev-python/matplotlib/files/digest-matplotlib-0.651
-rw-r--r--dev-python/matplotlib/matplotlib-0.65.ebuild38
4 files changed, 52 insertions, 5 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index ef653b860faa..64f951e8f1ba 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.1 2004/12/05 12:16:30 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.2 2004/12/20 00:30:06 kloeri Exp $
+
+*matplotlib-0.65 (20 Dec 2004)
+
+ 20 Dec 2004; Bryan Østergaard <kloeri@gentoo.org>
+ +matplotlib-0.65.ebuild:
+ Version bump, new ebuild by Fernando Serboncini <fserb@terra.com.br>
05 Dec 2004; Bryan Østergaard <kloeri@gentoo.org> :
Initial import, ebuild by Fernando A. Serboncini <fserb@terra.com.br> in bug
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 4e30b45daf85..e0018e3e4114 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -1,14 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 c68def4f7fe72c5c921dcf0b20954c8d ChangeLog 359
+MD5 55bb508f394af3b25f992f82d76eeb0d ChangeLog 543
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 163a349d41b791806f0b957dba684494 matplotlib-0.65.ebuild 1017
MD5 d55461a29fc353ff2a9ba538a04cd6c7 matplotlib-0.64.ebuild 1012
MD5 cd423139ef7e6085b17b6a145259e4c3 files/digest-matplotlib-0.64 68
+MD5 0ca8fafc829fa8440e2e63023cc9b2fc files/digest-matplotlib-0.65 68
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBsvw/ugEuf3OQ0akRAiheAJoC4upoZhRT2bPNErTSOT2v0E5j+ACcC8Tx
-dq/rkKmNUFXgswuKFSwUMRY=
-=HsCg
+iD8DBQFBxh0XugEuf3OQ0akRAsmGAJ43IlCQQK3HEolTmVDgyvucj0oqUQCdHXMd
+7221i1h+6n8Io0Bn4GM1la8=
+=KDKg
-----END PGP SIGNATURE-----
diff --git a/dev-python/matplotlib/files/digest-matplotlib-0.65 b/dev-python/matplotlib/files/digest-matplotlib-0.65
new file mode 100644
index 000000000000..b4731b5260a7
--- /dev/null
+++ b/dev-python/matplotlib/files/digest-matplotlib-0.65
@@ -0,0 +1 @@
+MD5 9fac4a2f0d0ee7b06b42a42ff4b600bd matplotlib-0.65.tar.gz 2117000
diff --git a/dev-python/matplotlib/matplotlib-0.65.ebuild b/dev-python/matplotlib/matplotlib-0.65.ebuild
new file mode 100644
index 000000000000..573d57201d39
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.65.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.65.ebuild,v 1.1 2004/12/20 00:30:06 kloeri Exp $
+
+inherit distutils virtualx
+
+DESCRIPTION="matplotlib is a pure python plotting library designed to bring publication quality plotting to python with a syntax familiar to matlab users."
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="as-is"
+
+DEPEND="virtual/python
+ >=dev-python/numeric-22
+ >=dev-python/pygtk-1.99.16"
+
+src_compile() {
+ export maketype="distutils_src_compile"
+ virtualmake "$*"
+}
+
+src_install() {
+ export maketype="distutils_src_install"
+ virtualmake "$*"
+ distutils_python_version
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py examples/README
+ insinfo /usr/share/doc/${PF}/examples/data
+ doins examples/data/*.dat
+ fi
+}
+