summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2006-09-20 17:25:11 +0000
committerRob Cakebread <pythonhead@gentoo.org>2006-09-20 17:25:11 +0000
commitc56178d1bbb041564000137938031515606f55d0 (patch)
treef222599c35ac1dadeb325e84b6ef0a721641ea9b /dev-python/logilab-common/files
parentUse new glproto for eye candy to work properly. (diff)
downloadhistorical-c56178d1bbb041564000137938031515606f55d0.tar.gz
historical-c56178d1bbb041564000137938031515606f55d0.tar.bz2
historical-c56178d1bbb041564000137938031515606f55d0.zip
Fix import from future error with Python 2.5
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'dev-python/logilab-common/files')
-rw-r--r--dev-python/logilab-common/files/digest-logilab-common-0.9.32
-rw-r--r--dev-python/logilab-common/files/logilab-common-setup.py.patch15
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/logilab-common/files/digest-logilab-common-0.9.3 b/dev-python/logilab-common/files/digest-logilab-common-0.9.3
index e77aef27c6c0..98ac8c9100fe 100644
--- a/dev-python/logilab-common/files/digest-logilab-common-0.9.3
+++ b/dev-python/logilab-common/files/digest-logilab-common-0.9.3
@@ -1 +1,3 @@
MD5 bfbe68606f2448b58836fb79b2582e71 common-0.9.3.tar.gz 156335
+RMD160 cc26062a61f4d1dcd05feda9baa4ef22920b4aac common-0.9.3.tar.gz 156335
+SHA256 6794620f5663442246f6ae1bb6695fd120a1a6024c455da457ae4037b3ee6826 common-0.9.3.tar.gz 156335
diff --git a/dev-python/logilab-common/files/logilab-common-setup.py.patch b/dev-python/logilab-common/files/logilab-common-setup.py.patch
new file mode 100644
index 000000000000..fe384d264f02
--- /dev/null
+++ b/dev-python/logilab-common/files/logilab-common-setup.py.patch
@@ -0,0 +1,15 @@
+--- setup.py.orig 2006-09-20 09:26:15.000000000 -0700
++++ setup.py 2006-09-20 09:26:50.000000000 -0700
+@@ -15,11 +15,11 @@
+ # You should have received a copy of the GNU General Public License along with
+ # this program; if not, write to the Free Software Foundation, Inc.,
+ # 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
++from __future__ import nested_scopes
+ """ Generic Setup script, takes package info from __pkginfo__.py file """
+
+ __revision__ = '$Id: setup.py,v 1.23 2004/05/27 12:07:23 syt Exp $'
+
+-from __future__ import nested_scopes
+ import os
+ import sys
+ import shutil