summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2004-11-21 18:03:32 +0000
committerChris Bainbridge <chrb@gentoo.org>2004-11-21 18:03:32 +0000
commitbe001893c3d92cf7295287677393021d6c97e0a6 (patch)
tree7c515f5d13794b7a12dfad5126814e1ec87976e3 /dev-python/imaging
parentAdded to ~amd64, bug #71962 (diff)
downloadhistorical-be001893c3d92cf7295287677393021d6c97e0a6.tar.gz
historical-be001893c3d92cf7295287677393021d6c97e0a6.tar.bz2
historical-be001893c3d92cf7295287677393021d6c97e0a6.zip
xv is required by Image.show()
Diffstat (limited to 'dev-python/imaging')
-rw-r--r--dev-python/imaging/ChangeLog5
-rw-r--r--dev-python/imaging/Manifest6
-rw-r--r--dev-python/imaging/files/digest-imaging-1.1.4-r11
-rw-r--r--dev-python/imaging/imaging-1.1.4-r1.ebuild59
4 files changed, 68 insertions, 3 deletions
diff --git a/dev-python/imaging/ChangeLog b/dev-python/imaging/ChangeLog
index a28c9dc03754..ebffb6934241 100644
--- a/dev-python/imaging/ChangeLog
+++ b/dev-python/imaging/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/imaging
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.6 2004/11/01 10:32:58 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/ChangeLog,v 1.7 2004/11/21 18:03:32 chrb Exp $
+
+ 21 Nov 2004; Chris Bainbridge <chrb@gentoo.org> :
+ xv is required by Image.show(). marked ~amd64 as xv is.
01 Nov 2004; Joseph Jezak <josejx@gentoo.org> imaging-1.1.3-r2.ebuild:
Marked ppc stable.
diff --git a/dev-python/imaging/Manifest b/dev-python/imaging/Manifest
index 23e042dcbb25..29daf83447c1 100644
--- a/dev-python/imaging/Manifest
+++ b/dev-python/imaging/Manifest
@@ -1,10 +1,11 @@
-MD5 41a12f1b3b024958f407ca7ea157de04 ChangeLog 3809
+MD5 ca569eee6673aab5b707490e8c35d8b2 ChangeLog 3918
MD5 8ff4dc32d0bae9804421a005049c0daf imaging-1.1.2-r2.ebuild 2657
MD5 13e44b975eebc8a9eeac54339203f335 imaging-1.1.3-r1.ebuild 1262
MD5 9805fe32ac63280bd98311a99300f233 imaging-1.1.3-r2.ebuild 1312
MD5 bddc0ad2819b48f5500be8ea154ba026 imaging-1.1.3.ebuild 2665
-MD5 972755ac7f93fa1553e758bb143996de imaging-1.1.4.ebuild 1397
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 972755ac7f93fa1553e758bb143996de imaging-1.1.4.ebuild 1397
+MD5 36af8de2cec8675d659026ffde736cc4 imaging-1.1.4-r1.ebuild 1434
MD5 7e1eafa229aad0303d6d04c88c1f89e6 files/digest-imaging-1.1.2-r2 65
MD5 a7c02afc37ec55a40b4369ace30d8fdb files/digest-imaging-1.1.3 65
MD5 a7c02afc37ec55a40b4369ace30d8fdb files/digest-imaging-1.1.3-r1 65
@@ -13,3 +14,4 @@ MD5 171777970922938dc6a815dd2b6a85de files/digest-imaging-1.1.4 65
MD5 8f3dd92ea003765c3f18202e3ee6be14 files/imaging-1.1.4-fPIC.patch 373
MD5 e937d8e178744db225745000b4e42128 files/imaging-1.1.4-ft-2.1.9.patch 301
MD5 d0b3528fb0e74be99cf9ac5e9372e317 files/imaging-1.1.4-setup.py.patch 374
+MD5 171777970922938dc6a815dd2b6a85de files/digest-imaging-1.1.4-r1 65
diff --git a/dev-python/imaging/files/digest-imaging-1.1.4-r1 b/dev-python/imaging/files/digest-imaging-1.1.4-r1
new file mode 100644
index 000000000000..9ed5eedc0531
--- /dev/null
+++ b/dev-python/imaging/files/digest-imaging-1.1.4-r1
@@ -0,0 +1 @@
+MD5 d2c03c25a9a0128832137dd536da88da Imaging-1.1.4.tar.gz 416338
diff --git a/dev-python/imaging/imaging-1.1.4-r1.ebuild b/dev-python/imaging/imaging-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..cbd22e8d0d6a
--- /dev/null
+++ b/dev-python/imaging/imaging-1.1.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imaging/imaging-1.1.4-r1.ebuild,v 1.1 2004/11/21 18:03:32 chrb Exp $
+
+inherit distutils eutils
+
+MY_P=${P/imaging/Imaging}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Python Imaging Library (PIL)"
+HOMEPAGE="http://www.pythonware.com/products/pil/index.htm"
+SRC_URI="http://www.effbot.org/downloads/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc alpha ~amd64"
+IUSE="tcltk"
+
+DEPEND="virtual/python
+ >=media-libs/jpeg-6a
+ >=sys-libs/zlib-0.95
+ >=media-libs/freetype-2.1.5
+ tcltk? ( dev-lang/tk )"
+
+RDEPEND="${DEPEND}
+ media-gfx/xv"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-setup.py.patch
+ epatch ${FILESDIR}/${P}-fPIC.patch
+ epatch ${FILESDIR}/${P}-ft-2.1.9.patch
+}
+
+src_compile() {
+ export OPT=${CFLAGS}
+
+ #Build the core imaging library (libImaging.a)
+ cd ${S}/libImaging
+ econf || die "econf failed"
+ #Not configured by configure
+ sed -e "s:\(JPEGINCLUDE=[[:blank:]]*/usr/\)local/\(include\).*:\1\2:" \
+ -i Makefile
+ emake || die
+ cd ${S}; distutils_src_compile
+}
+
+src_install() {
+ local mydoc="CHANGES* CONTENTS"
+ distutils_src_install
+ distutils_python_version
+
+ # install headers required by media-gfx/sketch
+ insinto "${ROOT}/usr/include/python${PYVER}"
+ doins libImaging/Imaging.h
+ doins libImaging/ImPlatform.h
+ doins libImaging/ImConfig.h
+}