summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-10-04 15:43:18 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-10-04 15:43:18 +0000
commit33c0a426794c78276a091020b290ca3178cb2b4f (patch)
treef5a69fc63949f930bdfef41cb41c67b5d6f46c57 /dev-python/h5py/h5py-2.1.0.ebuild
parentadded prefix support (bug #433852) (diff)
downloadhistorical-33c0a426794c78276a091020b290ca3178cb2b4f.tar.gz
historical-33c0a426794c78276a091020b290ca3178cb2b4f.tar.bz2
historical-33c0a426794c78276a091020b290ca3178cb2b4f.zip
Version bump
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'dev-python/h5py/h5py-2.1.0.ebuild')
-rw-r--r--dev-python/h5py/h5py-2.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/h5py/h5py-2.1.0.ebuild b/dev-python/h5py/h5py-2.1.0.ebuild
new file mode 100644
index 000000000000..da1732f45416
--- /dev/null
+++ b/dev-python/h5py/h5py-2.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.1.0.ebuild,v 1.1 2012/10/04 15:43:18 xarthisius Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython 2.7-pypy-*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="A simple Python interface to HDF5 files."
+HOMEPAGE="http://h5py.alfven.org/ http://code.google.com/p/h5py/ http://pypi.python.org/pypi/h5py"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="sci-libs/hdf5
+ dev-python/numpy"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( dev-python/unittest2 )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"