summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-13 09:32:35 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-13 09:32:35 +0000
commit84c5516a2fb6edd21a0dc907b7684ff31ae9f185 (patch)
tree65b488058ad3da681575997bd48b1c5be10ffa1a /dev-python/gtkhtml-python
parentRemove also graphite useflag. (diff)
downloadhistorical-84c5516a2fb6edd21a0dc907b7684ff31ae9f185.tar.gz
historical-84c5516a2fb6edd21a0dc907b7684ff31ae9f185.tar.bz2
historical-84c5516a2fb6edd21a0dc907b7684ff31ae9f185.zip
Finally fix horribly slow python libs detection (bug #344231).
Package-Manager: portage-2.2.0_alpha121/cvs/Linux x86_64
Diffstat (limited to 'dev-python/gtkhtml-python')
-rw-r--r--dev-python/gtkhtml-python/ChangeLog6
-rw-r--r--dev-python/gtkhtml-python/files/gtkhtml-python-2.25.3-python-libs.patch59
-rw-r--r--dev-python/gtkhtml-python/gtkhtml-python-2.25.3.ebuild15
3 files changed, 76 insertions, 4 deletions
diff --git a/dev-python/gtkhtml-python/ChangeLog b/dev-python/gtkhtml-python/ChangeLog
index 5f790d4648ed..4c306066b535 100644
--- a/dev-python/gtkhtml-python/ChangeLog
+++ b/dev-python/gtkhtml-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/gtkhtml-python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkhtml-python/ChangeLog,v 1.22 2012/02/24 08:57:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkhtml-python/ChangeLog,v 1.23 2012/08/13 09:28:20 tetromino Exp $
+
+ 13 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gtkhtml-python-2.25.3.ebuild, +files/gtkhtml-python-2.25.3-python-libs.patch:
+ Finally fix horribly slow python libs detection (bug #344231).
24 Feb 2012; Patrick Lauer <patrick@gentoo.org> gtkhtml-python-2.25.3.ebuild:
Restricting pypy and jython
diff --git a/dev-python/gtkhtml-python/files/gtkhtml-python-2.25.3-python-libs.patch b/dev-python/gtkhtml-python/files/gtkhtml-python-2.25.3-python-libs.patch
new file mode 100644
index 000000000000..ab691272cbb6
--- /dev/null
+++ b/dev-python/gtkhtml-python/files/gtkhtml-python-2.25.3-python-libs.patch
@@ -0,0 +1,59 @@
+From 7824fd5291f570de3c2c64185035d1a6a0a3445a Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 13 Aug 2012 04:42:47 -0400
+Subject: [PATCH] Replace horrible slow python libs search
+
+---
+ acinclude.m4 | 36 ++----------------------------------
+ 1 files changed, 2 insertions(+), 34 deletions(-)
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 8694a65..f5373eb 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -59,40 +59,8 @@ $1],dnl
+ [AC_MSG_RESULT(not found)
+ $2])
+ CPPFLAGS="$save_CPPFLAGS"
+-
+- # This bit is copied from Planner. murrayc.
+- # Check for Python library path
+- AC_MSG_CHECKING([for Python library path])
+-
+- # Win32 has libpython25.a instead of libpython2.5.a, so we look
+- # for both. TODO: Only look for libpython25.a on Windows, and for
+- # libpython2.5.a on unix.
+- WIN32_PYTHON_VERSION=`echo $PYTHON_VERSION | sed "s,\.,,"`
+-
+- python_path=`dirname $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- if test -e "$i"; then
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$PYTHON_VERSION"
+- break
+- fi
+-
+- # Additionally test WIN32_PYTHON_VERSION
+- python_path=`find $i -type f -name libpython$WIN32_PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$WIN32_PYTHON_VERSION"
+- break
+- fi
+- fi
+- done
+-
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
+- AC_MSG_RESULT([$python_path])
+- if test -z "$python_path" ; then
+- AC_MSG_ERROR([cannot find Python library path])
+- fi
+- AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -l$python_lib"])
++PYTHON_LDFLAGS=`$PYTHON -c "import distutils.sysconfig; print('-L%s -lpython${PYTHON_VERSION}' % distutils.sysconfig.get_config_var('LIBDIR'))"`
++AC_SUBST([PYTHON_LDFLAGS],["$PYTHON_LDFLAGS"])
+ ])
+
+ dnl
+--
+1.7.8.6
+
diff --git a/dev-python/gtkhtml-python/gtkhtml-python-2.25.3.ebuild b/dev-python/gtkhtml-python/gtkhtml-python-2.25.3.ebuild
index e52e203e8ba7..df83c793e308 100644
--- a/dev-python/gtkhtml-python/gtkhtml-python-2.25.3.ebuild
+++ b/dev-python/gtkhtml-python/gtkhtml-python-2.25.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkhtml-python/gtkhtml-python-2.25.3.ebuild,v 1.9 2012/02/24 08:57:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gtkhtml-python/gtkhtml-python-2.25.3.ebuild,v 1.10 2012/08/13 09:28:20 tetromino Exp $
EAPI="2"
G_PY_PN="gnome-python-extras"
@@ -9,7 +9,7 @@ SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="2"
RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-inherit gnome-python-common
+inherit autotools eutils gnome-python-common
PVP="$(get_version_component_range 1-2)"
SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2"
@@ -21,6 +21,15 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="examples"
RDEPEND="=gnome-extra/gtkhtml-2*"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+# eautoreconf needs gnome-base/gnome-common
EXAMPLES="examples/gtkhtml2/*"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-libs.patch" #344231
+ eautoreconf
+ gnome-python-common_src_prepare
+}