summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-16 22:48:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-16 22:48:21 +0000
commit0dbd77432c4bcd1c12349e3305c629937b29270d (patch)
treef6f453fe68af8a33b8d5d65fc46a5d2db1631074 /dev-python/gdl-python
parentAutomated update of use.local.desc (diff)
downloadhistorical-0dbd77432c4bcd1c12349e3305c629937b29270d.tar.gz
historical-0dbd77432c4bcd1c12349e3305c629937b29270d.tar.bz2
historical-0dbd77432c4bcd1c12349e3305c629937b29270d.zip
Initial import of gnome-python-extras split ebuilds. This package installs bindings for the gdl package.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64
Diffstat (limited to 'dev-python/gdl-python')
-rw-r--r--dev-python/gdl-python/ChangeLog11
-rw-r--r--dev-python/gdl-python/gdl-python-2.19.1.ebuild39
-rw-r--r--dev-python/gdl-python/metadata.xml6
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/gdl-python/ChangeLog b/dev-python/gdl-python/ChangeLog
new file mode 100644
index 000000000000..e972da972b73
--- /dev/null
+++ b/dev-python/gdl-python/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/gdl-python
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/ChangeLog,v 1.1 2008/10/16 22:48:21 eva Exp $
+
+*gdl-python-2.19.1 (16 Oct 2008)
+
+ 16 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> +metadata.xml,
+ +gdl-python-2.19.1.ebuild:
+ Initial import of gnome-python-extras split ebuilds. This package installs
+ bindings for the gdl package.
+
diff --git a/dev-python/gdl-python/gdl-python-2.19.1.ebuild b/dev-python/gdl-python/gdl-python-2.19.1.ebuild
new file mode 100644
index 000000000000..f73571f3acfb
--- /dev/null
+++ b/dev-python/gdl-python/gdl-python-2.19.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/gdl-python-2.19.1.ebuild,v 1.1 2008/10/16 22:48:21 eva Exp $
+
+G_PY_PN="gnome-python-extras"
+
+inherit gnome-python-common
+
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2
+ mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/gdl-0.6.1"
+DEPEND="${RDEPEND}"
+
+EXAMPLES="examples/gdl/*"
+
+pkg_setup() {
+ # we need gdl-gnome
+ if ! built_with_use --missing true dev-libs/gdl gnome; then
+ eerror "If you want to build ${PN} you need to build dev-libs/gdl with"
+ eerror "the the 'gnome' USE flag."
+ die "gdl must be built with USE='gnome'"
+ fi
+
+ gnome-python-common_pkg_setup
+}
+
+src_unpack() {
+ gnome-python-common_src_unpack
+
+ epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
+ eautoreconf
+}
diff --git a/dev-python/gdl-python/metadata.xml b/dev-python/gdl-python/metadata.xml
new file mode 100644
index 000000000000..9b1bc26a9df2
--- /dev/null
+++ b/dev-python/gdl-python/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<herd>python</herd>
+</pkgmetadata>