summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-08 00:08:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-08 00:08:55 +0000
commit34350c576ec14d646d469aa5d87869079f00424e (patch)
tree5bc6c0c23092f58eeee82d8fac047bbdc0a351af /dev-python/egenix-mx-base
parentFix dependencies (bug #321999). (diff)
downloadhistorical-34350c576ec14d646d469aa5d87869079f00424e.tar.gz
historical-34350c576ec14d646d469aa5d87869079f00424e.tar.bz2
historical-34350c576ec14d646d469aa5d87869079f00424e.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/egenix-mx-base')
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild
deleted file mode 100644
index afb2c2f9aad4..000000000000
--- a/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild,v 1.10 2009/10/10 15:42:03 grobian Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils flag-o-matic
-
-DESCRIPTION="eGenix utils for Python"
-HOMEPAGE="http://www.egenix.com/products/python/mxBase"
-SRC_URI="http://downloads.egenix.com/python/${P}.tar.gz"
-
-LICENSE="eGenixPublic-1.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-RESTRICT_PYTHON_ABIS="3*"
-
-PYTHON_MODNAME="mx"
-
-src_prepare() {
- distutils_src_prepare
- # doesn't play well with -fstack-protector (#63762)
- rm "mx/TextTools/Examples/pytag.py"
-
- # We do the optimization ourselves
- sed -i \
- -e 's/^\(optimize\) = 1/\1 = 0/' \
- setup.cfg || die "sed failed"
-
- # And we don't want the docs in site-packages
- sed -i \
- -e '/\/Doc\//d' \
- egenix_mx_base.py || die "sed failed"
-}
-
-src_compile() {
- replace-flags "-O[3s]" "-O2"
- distutils_src_compile
-}
-
-src_install() {
- [[ -z ${ED} ]] && local ED=${D}
- distutils_src_install
- dohtml -a html -r mx
- insinto /usr/share/doc/${PF}
- find "${S}" -iname "*.pdf" | xargs doins
-
- installation_of_headers() {
- dodir "$(python_get_includedir)/mx"
- find "${ED}$(python_get_sitedir)/mx" -type f -name "*.h" -print0 | while read -d $'\0' header; do
- mv -f "${header}" "${ED}$(python_get_includedir)/mx"
- done
- }
- python_execute_function --action-message 'Installation of headers with Python ${PYTHON_ABI}' installation_of_headers
-}