summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCorentin Chary <iksaif@gentoo.org>2012-05-08 12:16:31 +0000
committerCorentin Chary <iksaif@gentoo.org>2012-05-08 12:16:31 +0000
commitd028e206e68612d4cd33c05bd4f5c48fb092df0b (patch)
tree03c378efb978648ae1cd7eac6708db59559b0397 /dev-python/django-oauth-plus/django-oauth-plus-2.0.ebuild
parentversion bump (diff)
downloadhistorical-d028e206e68612d4cd33c05bd4f5c48fb092df0b.tar.gz
historical-d028e206e68612d4cd33c05bd4f5c48fb092df0b.tar.bz2
historical-d028e206e68612d4cd33c05bd4f5c48fb092df0b.zip
New ebuild for django-oauth-plus.
Package-Manager: portage-2.1.10.57/cvs/Linux x86_64
Diffstat (limited to 'dev-python/django-oauth-plus/django-oauth-plus-2.0.ebuild')
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.0.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.0.ebuild
new file mode 100644
index 000000000000..0dbb645208ff
--- /dev/null
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-oauth-plus/django-oauth-plus-2.0.ebuild,v 1.1 2012/05/08 12:16:31 iksaif Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
+HOMEPAGE="http://pypi.python.org/pypi/django-oauth-plus http://code.welldev.org/django-oauth-plus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-python/django-1.2.4
+ >=dev-python/oauth2-1.5.170"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ dev-python/setuptools_hg"
+
+PYTHON_MODNAME="oauth_provider"
+
+src_install() {
+ distutils_src_install
+
+ delete_examples() {
+ rm -fr "${ED}$(python_get_sitedir)/examples"
+ }
+ python_execute_function -q delete_examples
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}