summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-09 19:11:17 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-09 19:11:17 +0000
commit882a8bc20630c2429f353a3773c5ad5e634044fb (patch)
tree49629bb118e14ea6b9098e59d9556af3f59ef0f8 /dev-python/cython/cython-0.18-r1.ebuild
parentVersion bump. (diff)
downloadhistorical-882a8bc20630c2429f353a3773c5ad5e634044fb.tar.gz
historical-882a8bc20630c2429f353a3773c5ad5e634044fb.tar.bz2
historical-882a8bc20630c2429f353a3773c5ad5e634044fb.zip
As explained in bug 456318, numpy is really a dependency when compiling code that uses numpy or in tests. Therefore, adjust the dep. Thanks to Matěj Laitl for insight.
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0x42B9401D
Diffstat (limited to 'dev-python/cython/cython-0.18-r1.ebuild')
-rw-r--r--dev-python/cython/cython-0.18-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/cython/cython-0.18-r1.ebuild b/dev-python/cython/cython-0.18-r1.ebuild
index ec6e4c266b91..feea0d00904d 100644
--- a/dev-python/cython/cython-0.18-r1.ebuild
+++ b/dev-python/cython/cython-0.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.18-r1.ebuild,v 1.2 2013/02/09 17:56:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.18-r1.ebuild,v 1.3 2013/02/09 19:11:12 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
@@ -17,11 +17,12 @@ SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc numpy"
+IUSE="doc test"
-RDEPEND="numpy? ( >=dev-python/numpy-1.6.1-r1[${PYTHON_USEDEP}] )"
+RDEPEND=""
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/numpy-1.6.1-r1[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${MY_PN}-${PV%_*}"