summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-19 21:27:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-19 21:27:12 +0000
commitcad3b9d43aed01b225632915e5284e839cedd679 (patch)
tree27fd68272170310c9d157554264ff2781c4f9e1f /dev-python/coverage
parentStable on amd64 wrt bug #337981 (diff)
downloadhistorical-cad3b9d43aed01b225632915e5284e839cedd679.tar.gz
historical-cad3b9d43aed01b225632915e5284e839cedd679.tar.bz2
historical-cad3b9d43aed01b225632915e5284e839cedd679.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/coverage-3.2.ebuild33
-rw-r--r--dev-python/coverage/coverage-3.3.ebuild33
-rw-r--r--dev-python/coverage/coverage-3.4_beta2.ebuild28
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/coverage/coverage-3.2.ebuild b/dev-python/coverage/coverage-3.2.ebuild
deleted file mode 100644
index 408ba92a3bdd..000000000000
--- a/dev-python/coverage/coverage-3.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/coverage-3.2.ebuild,v 1.11 2010/04/16 15:12:59 ranger Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Measures code coverage during Python execution"
-HOMEPAGE="http://nedbatchelder.com/code/coverage/ http://pypi.python.org/pypi/coverage"
-SRC_URI="http://pypi.python.org/packages/source/c/coverage/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="test"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- test? ( >=dev-python/nose-0.10.3 )"
-
-PYTHON_MODNAME="coverage"
-
-src_test() {
- testing() {
- # Future version of dev-python/nose will support Python 3.
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" nosetests
- }
- python_execute_function testing
-}
diff --git a/dev-python/coverage/coverage-3.3.ebuild b/dev-python/coverage/coverage-3.3.ebuild
deleted file mode 100644
index db1183882145..000000000000
--- a/dev-python/coverage/coverage-3.3.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/coverage-3.3.ebuild,v 1.1 2010/03/01 22:12:00 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Measures code coverage during Python execution"
-HOMEPAGE="http://nedbatchelder.com/code/coverage/ http://pypi.python.org/pypi/coverage"
-SRC_URI="http://pypi.python.org/packages/source/c/coverage/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="test"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- test? ( >=dev-python/nose-0.10.3 )"
-
-PYTHON_MODNAME="coverage"
-
-src_test() {
- testing() {
- # Future version of dev-python/nose will support Python 3.
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" nosetests
- }
- python_execute_function testing
-}
diff --git a/dev-python/coverage/coverage-3.4_beta2.ebuild b/dev-python/coverage/coverage-3.4_beta2.ebuild
deleted file mode 100644
index a540828c3b84..000000000000
--- a/dev-python/coverage/coverage-3.4_beta2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/coverage-3.4_beta2.ebuild,v 1.1 2010/09/17 20:51:05 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_P="${PN}-${PV/_beta/b}"
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="http://nedbatchelder.com/code/coverage/ http://pypi.python.org/pypi/coverage"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-PYTHON_MODNAME="coverage"