summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-29 03:10:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-29 03:10:57 +0000
commita5e3b321d9b42435666a20810bec926e40e4e9b5 (patch)
treea188ed0781cef5c794261c609930c4087ffc368a /dev-php
parentversion bump (diff)
downloadhistorical-a5e3b321d9b42435666a20810bec926e40e4e9b5.tar.gz
historical-a5e3b321d9b42435666a20810bec926e40e4e9b5.tar.bz2
historical-a5e3b321d9b42435666a20810bec926e40e4e9b5.zip
version bump
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/Manifest4
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.32
-rw-r--r--dev-php/mod_php/mod_php-4.3.3.ebuild165
-rw-r--r--dev-php/php/ChangeLog7
-rw-r--r--dev-php/php/Manifest22
5 files changed, 187 insertions, 13 deletions
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index 5914a9320b93..2498a2ff125d 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -3,9 +3,9 @@ MD5 30e25e91644699efc5a97ac2f776b1bd mod_php-4.3.2-r5.ebuild 5073
MD5 5da4975d38a64cfed58d48061a0ebcad mod_php-4.3.3_rc3.ebuild 5092
MD5 4f9a379cbc9711222ee3ab765fb2fea2 mod_php-4.3.2-r2.ebuild 3657
MD5 4bc93aba5f4a7afb37bcf4bd4141f63b mod_php-4.3.2-r4.ebuild 4941
-MD5 57313b5674161e2603ab819787bc02dc mod_php-4.3.3.ebuild 4865
+MD5 50e9fd4603931d51ef846111c8ab4cd2 mod_php-4.3.3.ebuild 4862
MD5 e26ab944bb819b5a7423acf58a47118b mod_php-4.3.2-r1.ebuild 2720
-MD5 17ad26d308390ba71d2b2cb8cd4fdb07 ChangeLog 20514
+MD5 d3c1ced303e0e3c25acfcbfc2cd149d8 ChangeLog 20635
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 435c911b2d32f4afb64abaf0de65b924 mod_php-4.3.2-r3.ebuild 4903
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.3 b/dev-php/mod_php/files/digest-mod_php-4.3.3
new file mode 100644
index 000000000000..1fecdf01d76d
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.3
@@ -0,0 +1,2 @@
+MD5 1171d96104e2ff2cff9e19789a4a1536 php-4.3.3.tar.bz2 3711877
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/mod_php/mod_php-4.3.3.ebuild b/dev-php/mod_php/mod_php-4.3.3.ebuild
new file mode 100644
index 000000000000..0026e3ef6c96
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.3.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.3.ebuild,v 1.1 2003/08/29 03:08:19 robbat2 Exp $
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~arm"
+EXCLUDE_DB4_FIX=1
+EXCLUDE_PEAR_FIX=1
+
+detectapache() {
+ local domsg=
+ [ -n "$1" ] && domsg=1
+ HAVE_APACHE1=
+ HAVE_APACHE2=
+ has_version '=net-www/apache-1*' && HAVE_APACHE1=1
+ has_version '=net-www/apache-2*' && HAVE_APACHE2=1
+
+ [ -n "${HAVE_APACHE1}" ] && APACHEVER=1
+ [ -n "${HAVE_APACHE2}" ] && APACHEVER=2
+ [ -n "${HAVE_APACHE1}" ] && [ -n "${HAVE_APACHE2}" ] && APACHEVER='both'
+
+ case "${APACHEVER}" in
+ 1) [ -n "${domsg}" ] && einfo 'Apache1 only detected' ;;
+ 2) [ -n "${domsg}" ] && einfo 'Apache2 only detected';;
+ both)
+ if [ "`use apache2`" ]; then
+ [ -n "${domsg}" ] && einfo "Multiple Apache versions detected, using Apache2 (USE=apache2)"
+ APACHEVER=2
+ else
+ [ -n "${domsg}" ] && einfo 'Multiple Apache versions detected, using Apache1 (USE=-apache2)'
+ APACHEVER=1
+ fi ;;
+ *) if [ -n "${domsg}" ]; then
+ MSG="Unknown Apache version!"; eerror $MSG ; die $MSG
+ else
+ APACHEVER=0
+ fi; ;;
+ esac
+}
+
+detectapache
+
+SLOT="${APACHEVER}"
+[ "${APACHEVER}" -eq '2' ] && USE_APACHE2='2' || USE_APACHE2=''
+
+PHPSAPI="apache${APACHEVER}"
+
+# BIG FAT WARNING!
+# the php eclass requires the PHPSAPI setting!
+# In this case the PHPSAPI setting is dependant on the detectapache function
+# above this point as well!
+inherit php eutils
+
+DEPEND="${DEPEND}
+ >=net-www/apache-1.3.26-r2
+ apache2? ( >=net-www/apache-2.0.43-r1 )"
+
+src_unpack() {
+ multiinstwarn
+ detectapache domsg
+ php_src_unpack
+}
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline"
+
+ # Every Apache2 MPM EXCEPT prefork needs Zend Thread Safety
+ if [ -n "${USE_APACHE2}" ]; then
+ APACHE2_MPM="`apache2 -l |egrep 'worker|prechild|leader|threadpool|prefork'|xargs|cut -d. -f1`"
+ case "${APACHE2_MPM}" in
+ prefork) ;;
+ *) myconf="${myconf} --enable-experimental-zts" ;;
+ esac;
+ fi
+
+ #use apache2 \
+ myconf="${myconf} --with-apxs${USE_APACHE2}=/usr/sbin/apxs${USE_APACHE2}"
+
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+ einfo "Adding extra symlink to php.ini for Apache${USE_APACHE2}"
+ dodir /etc/apache${USE_APACHE2}/conf/
+ dodir ${PHPINIDIRECTORY}
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache${USE_APACHE2}/conf/${PHPINIFILENAME}
+
+ einfo "Adding extra symlink to Apache${USE_APACHE2} extramodules for PHP"
+ dosym /usr/lib/apache${USE_APACHE2}-extramodules ${PHPINIDIRECTORY}/lib
+ exeinto /usr/lib/apache${USE_APACHE2}-extramodules
+ einfo "Installing mod_php shared object now"
+ doexe .libs/libphp4.so
+
+ if [ -n "${USE_APACHE2}" ] ; then
+ einfo "Installing a Apache2 config for PHP (70_mod_php.conf)"
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ else
+ einfo "Installing a Apache config for PHP (mod_php.conf)"
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache/conf/addon-modules/${PHPINIFILENAME}
+ fi
+}
+
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ ewarn "This is a CHANGE from previous behavior, which was \"-D PHP\""
+ ewarn "This is for the upcoming PHP5 support. The ebuild will attempt"
+ ewarn "to make this update between PHP and PHP4 automatically"
+}
+
+multiinstwarn() {
+ ewarn "Due to some previous bloopers with PHP and slotting, you may have"
+ ewarn "multiple copies of mod_php installed. Please look at the autoclean"
+ ewarn "output at the end of the emerge and unmerge all but relevant"
+ ewarn "copies."
+}
+
+apache2fix() {
+ einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
+ local oldfile="/etc/conf.d/apache2.old.`date +%Y%m%d%H%M%S`"
+ cp /etc/conf.d/apache2 ${oldfile}
+ sed -re 's,-D PHP\>,-D PHP4,g' ${oldfile} <${oldfile} >/etc/conf.d/apache2
+}
+
+
+pkg_preinst() {
+ multiinstwarn
+ [ "${APACHEVER}" -eq '2' ] && apache2fix
+ php_pkg_preinst
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ multiinstwarn
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ apache2msg
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP4\""
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ multiinstwarn
+ if [ -n "${USE_APACHE2}" ] ; then
+ apache2msg
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
+}
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index fcae6618dcff..8ae55becd204 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.56 2003/08/20 08:26:11 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.57 2003/08/29 03:10:57 robbat2 Exp $
+
+*php-4.3.3 (28 Aug 2003)
+
+ 28 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> php-4.3.3.ebuild:
+ version bump
20 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
add metadata.xml
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index 7a5f057897eb..72e5c769ea20 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -1,13 +1,15 @@
+MD5 4050f7ed6eb4c2864abf0eb05b5140a8 php-4.3.2-r3.ebuild 1141
+MD5 b5971dfa118d3b7b3a86044960ecc3f5 php-4.3.2.ebuild 2422
+MD5 69261b04b41d4699eb0c55b4b4a10f8e php-4.3.2-r2.ebuild 1184
+MD5 6118cb273654c1847c504406f57131da php-5.0_beta1.ebuild 1178
+MD5 4a6e3c863b81979863b6d39b7ab93246 ChangeLog 8655
+MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
+MD5 434ff51e4e7de5c6ce8bf855717de268 php-4.3.2-r1.ebuild 991
+MD5 ea2484027c9f59e90e55fcf59e6d8a46 php-4.3.3.ebuild 1216
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r1 137
-MD5 2a7311fb659555c4711a4ed8b70e9594 files/digest-php-5.0_beta1 65
-MD5 663577b8f4b90d61f245bb6052629194 files/pear_config.diff 422
-MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2 137
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r2 137
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r3 137
-MD5 7588d047b95d706759df29bdafceb4cf php-4.3.2-r1.ebuild 992
-MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
-MD5 0ad96393a56530df42b3aca284635593 php-5.0_beta1.ebuild 1179
-MD5 5541cf4177bfcf205012ed0da4cd38c0 php-4.3.2.ebuild 2423
-MD5 8893110f384462d0082e4171222ad880 php-4.3.2-r2.ebuild 1185
-MD5 aa2a0765e471ace0fff21b7441c996e5 php-4.3.2-r3.ebuild 1142
-MD5 e82a76acc6cf50e816b5eb1dc91037c3 ChangeLog 8656
+MD5 663577b8f4b90d61f245bb6052629194 files/pear_config.diff 422
+MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2 137
+MD5 e007fc4a17373504abd024180c0d0b3f files/digest-php-4.3.3 137
+MD5 2a7311fb659555c4711a4ed8b70e9594 files/digest-php-5.0_beta1 65