summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2008-02-28 19:07:40 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2008-02-28 19:07:40 +0000
commit9d5288ac4993d823efd73191d2b9ef79c3733b57 (patch)
tree67b569e9cf45a8aa704d1476843a0a580df2d006 /dev-php5/onphp/onphp-0.10.10.ebuild
parentlocal typo fix (diff)
downloadhistorical-9d5288ac4993d823efd73191d2b9ef79c3733b57.tar.gz
historical-9d5288ac4993d823efd73191d2b9ef79c3733b57.tar.bz2
historical-9d5288ac4993d823efd73191d2b9ef79c3733b57.zip
* double bump
* stabilization Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-php5/onphp/onphp-0.10.10.ebuild')
-rw-r--r--dev-php5/onphp/onphp-0.10.10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php5/onphp/onphp-0.10.10.ebuild b/dev-php5/onphp/onphp-0.10.10.ebuild
new file mode 100644
index 000000000000..3dbe7bc8cf17
--- /dev/null
+++ b/dev-php5/onphp/onphp-0.10.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.10.10.ebuild,v 1.1 2008/02/28 19:06:48 voxus Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+src_install() {
+ has_php
+
+ dodoc `find doc -maxdepth 1 -type f -print`
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ php-lib-r1_src_install ./ global.inc.php.tpl
+ php-lib-r1_src_install ./ `find core main meta -type f -print`
+}